Bug 92068 - cannot install waffle on SKL-Y
Summary: cannot install waffle on SKL-Y
Status: RESOLVED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-21 16:49 UTC by Humberto Israel Perez Rodriguez
Modified: 2015-09-26 21:43 UTC (History)
1 user (show)

See Also:
i915 platform: SKL
i915 features:


Attachments
dmesg_drm.debug=0x1e (990.67 KB, text/plain)
2015-09-21 16:49 UTC, Humberto Israel Perez Rodriguez
Details
dmesg_drm.debug=0x06 (188.63 KB, text/plain)
2015-09-21 16:50 UTC, Humberto Israel Perez Rodriguez
Details
make check-func (30.11 KB, text/plain)
2015-09-21 16:51 UTC, Humberto Israel Perez Rodriguez
Details
xradnr --verbose (7.21 KB, text/plain)
2015-09-21 16:51 UTC, Humberto Israel Perez Rodriguez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Humberto Israel Perez Rodriguez 2015-09-21 16:49:55 UTC
Created attachment 118387 [details]
dmesg_drm.debug=0x1e

Kernel drm-intel-testing-2015-08-28 b4c4542ba1abfb0d3d6913504502573bf2c62b12


==Bug detailed description==
--------------------------------------------------
cannot install waffle on SKL-Y , issues with i965_dri.so and libGL when try to install waffle on SKL-Y

==Attachments==
--------------------------------------------------

>dmesg_drm.debug=0x1e , which is the dmesg log with drm.debug=0x1e option enabled
>dmesg_drm.debug=0x06 , which is the dmesg log with drm.debug=0x06 option enabled 
>make check-func , which is the output of the command that fails
>xradnr , which is output of the command xrandr --verbose

==Steps to reproduce==
--------------------------------------------------
1-download waffle and cd waffle
2-cmake .
3-make
4-make check
5-make check-func
6-sudo make install

==Actual results==
--------------------------------------------------
after execute the command 5 from above shows the following errors :

libGL error: pci id for fd 7: 8086:191e, driver (null)
i965_dri.so does not support the 0x191e PCI ID.
libGL error: failed to create dri screen
libGL error: failed to load driver: i965


==Expected results==
--------------------------------------------------
waffle must be installed on SKL-Y

==Hardware configuration==
--------------------------------------------------

Platform: SKY LAKE Y A0 
CPU : Intel(R) Core(TM) m5-6Y57 CPU @ 1.10GHz (family: 6, model: 78  stepping: 3)
MCP : SKL-Y  D1 2+2 (ou ULX-D1)
QDF : QJK9 
CPU : SKL D0
Chipset PCH: Sunrise Point LP C1       
CRB : SKY LAKE Y LPDDR3 RVP3 CRB FAB2
Reworks : All Mandatories + FBS02,FBS03, F23, O-02 & O-06

-- Software --
Linux distribution: Ubuntu 14.04.03 LTS 64Bits
BIOS: 93.2


==Test Environment==
--------------------------------------------------

Kernel: tag drm-intel-testing-2015-07-31 (4.2-rc4) from git://anongit.freedesktop.org/drm-intel

Mesa: mesa-10.6.7 from http://cgit.freedesktop.org/mesa/mesa/
Mesa commit : 32efdc87cbf89cfe08ad9571cd756e27c803caa8

Xf86_video_intel: 2.99.917 from http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/
Xf86_video_intel commit : baec802b21387d04aebb10ac29e719a1800c5aa0


libdrm :libdrm-2.4.64 from http://cgit.freedesktop.org/mesa/drm/
libdrm commit : ab2fadabde3829b1ec56bd4756165dd9bd281488

Cairo: 1.14.2 from http://cgit.freedesktop.org/cairo
Cairo commit: 93422b3cb5e0ef8104b8194c8873124ce2f5ea2d

libva: libva-1.6.1 from http://cgit.freedesktop.org/libva/
libva commit : 613eb962b45fbbd1526d751e88e0d8897af6c0e0

intel-driver: 1.6.1. from http://cgit.freedesktop.org/vaapi/intel-driver
intel-driver commint : 35858c69166b845c59ca32e19a3dbb0b758df209


xorg: 1.17.99 installed with script git_xorg.sh

Xserver: xorg-server-1.17.2 from http://cgit.freedesktop.org/xorg/xserver
Xserver commit : 2123f7682d522619f101b05fb75efa75dabbe371


Kernel commit log:
commit b4c4542ba1abfb0d3d6913504502573bf2c62b12
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date:   Fri Aug 28 15:51:30 2015 +0200
drm-intel-nightly: 2015y-08m-28d-13h-50m-34s UTC integration manifest



If needed more information or you have any doubt do not hesitate to contact me
Comment 1 Humberto Israel Perez Rodriguez 2015-09-21 16:50:54 UTC
Created attachment 118388 [details]
dmesg_drm.debug=0x06
Comment 2 Humberto Israel Perez Rodriguez 2015-09-21 16:51:17 UTC
Created attachment 118389 [details]
make check-func
Comment 3 Humberto Israel Perez Rodriguez 2015-09-21 16:51:48 UTC
Created attachment 118390 [details]
xradnr --verbose
Comment 4 Matt Turner 2015-09-22 16:15:28 UTC
(In reply to Humberto Israel Perez Rodriguez from comment #0)
> libGL error: pci id for fd 7: 8086:191e, driver (null)
> i965_dri.so does not support the 0x191e PCI ID.
> libGL error: failed to create dri screen
> libGL error: failed to load driver: i965

The PCI ID has been in Mesa since 10.5.0.

I suspect you're not running the Mesa you think you are. 'glxinfo | grep Mesa' will confirm.
Comment 5 Humberto Israel Perez Rodriguez 2015-09-23 01:09:41 UTC
(In reply to Matt Turner from comment #4)
> (In reply to Humberto Israel Perez Rodriguez from comment #0)
> > libGL error: pci id for fd 7: 8086:191e, driver (null)
> > i965_dri.so does not support the 0x191e PCI ID.
> > libGL error: failed to create dri screen
> > libGL error: failed to load driver: i965
> 
> The PCI ID has been in Mesa since 10.5.0.
> 
> I suspect you're not running the Mesa you think you are. 'glxinfo | grep
> Mesa' will confirm.

i confirm that the version of mesa that i have is the 10.6.7 get from (glxinfo | grep Mesa) , as well i've noticed that if i run the command 'make check-func' as sudo it always takes the Mesa version 10.1.3 where this version doesnt has yet implemented the PCI ID, i think that this Mesa version is which it has by default Ubuntu, can you confirm this please ?

Other important thing here is that when i run the command 'make check-func' without sudo, i always have the following errors :

$make check-func
[ 50%] Built target threads_bundled
[ 50%] Built target waffle-1
[ 50%] Built target waffle_test
[ 50%] Built target gl_basic_test
test: pass:   gl_basic.glx_init
libGL: OpenDriver: trying /opt/X11R7/lib/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /opt/X11R7/lib/dri/swrast_dri.so
test: pass:   gl_basic.glx_gl_rgb
libGL: OpenDriver: trying /opt/X11R7/lib/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /opt/X11R7/lib/dri/swrast_dri.so
test: pass:   gl_basic.glx_gl_rgba
libGL: OpenDriver: trying /opt/X11R7/lib/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /opt/X11R7/lib/dri/swrast_dri.so


and i've noticed as well that if i do a symbolic link or copy the swrast_dri.so to the path /opt/X11R7/lib/dri/tls/, when i run the command 'glxinfo | grep Mesa' i got 
10.1.3 Mesa version , and when run for second time the same command only libGL ask for the path : libGL: OpenDriver: trying /opt/X11R7/lib/dri/tls/swrast_dri.so , strange looks like that libGL does not recognizes swrast_dri.so, I have no idea what can be.
Comment 6 Matt Turner 2015-09-23 01:30:49 UTC
Presumably you're setting some environment variables (LIBGL_DRIVERS_PATH, LD_LIBRARY_PATH) in order to use the Mesa you've built, but sudo doesn't keep environment variables.

See https://stackoverflow.com/questions/8633461/how-to-keep-environment-variables-when-using-sudo

(not that I think you should be running make check as root)

In any case, this is definitely not a bug.
Comment 7 Humberto Israel Perez Rodriguez 2015-09-23 01:38:55 UTC
(In reply to Matt Turner from comment #6)
> Presumably you're setting some environment variables (LIBGL_DRIVERS_PATH,
> LD_LIBRARY_PATH) in order to use the Mesa you've built, but sudo doesn't
> keep environment variables.
> 
> See
> https://stackoverflow.com/questions/8633461/how-to-keep-environment-
> variables-when-using-sudo
> 
> (not that I think you should be running make check as root)
> 
> In any case, this is definitely not a bug.

to confirm you that i'm not using sudo with make check command, only was a test to see if anything happened differently

my environment variables are :

export INSTALL_ROOT=/opt/X11R7
export PATH=/opt/X11R7/bin:$PATH
export LIBGL_DRIVERS_PATH=/opt/X11R7/lib/dri:/opt/X11R7/lib
export LD_LIBRARY_PATH=/opt/X11R7/lib:/opt/X11R7/lib32:/lib:/lib64:/usr/lib:/usr/lib64
export LIBGL_DEBUG=verbose
export PKG_CONFIG_PATH=/opt/X11R7/share/pkgconfig:/opt/X11R7/lib/pkgconfig:/usr/lib/pkgconfig:$PKG_CONFIG_PATH
export SW="env LIBGL_ALWAYS_SOFTWARE=1"
export LDFLAGS=" -L${INSTALL_ROOT}/lib  $LDFLAGS"
export ACLOCAL="aclocal -I ${INSTALL_ROOT}/share/aclocal"
export CMAKE_INCLUDE_PATH=/opt/X11R7/include/:$CMAKE_INCLUDE_PATH
export CMAKE_LIBRARY_PATH=/opt/X11R7/lib/:$CMAKE_LIBRARY_PATH
export DISPLAY=:0
Comment 8 Humberto Israel Perez Rodriguez 2015-09-26 17:51:20 UTC
i´m very confused because you guys close this bug without any explanation of why !
So i will always re open this bug unless i got a valid explanation of why this bug is an invalid bug , otherwise dont close this bug 

Please answer this question:

mattst88 / kenneth / jani.nikula

This bug still exist on SKL-Y
Comment 9 Ian Romanick 2015-09-26 21:43:39 UTC
Matt explaithe reason in comment #6. After reading comment#5, it is pretty obvious that this is user error, not software error.

I am closing this bug again.  Do not reopen it.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.