Bug 92070 - [HSW, BDW] arb_sync.clientwaitsync-timeout fails intermittently
Summary: [HSW, BDW] arb_sync.clientwaitsync-timeout fails intermittently
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 92625 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-09-21 22:12 UTC by Mark Janes
Modified: 2019-03-12 09:56 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2015-09-21 22:12:22 UTC
Occasionally, this piglit test fails on haswell with the following signature:

/tmp/build_root/m32/lib/piglit/bin/arb_sync-ClientWaitSync-timeout -auto -fbo
glClientWaitSync returned GL_CONDITION_SATISFIED.
Probe [0] failed. Expected: 17.000000  Observed: 0.000000
Probe [1] failed. Expected: 13.000000  Observed: 0.000000
Probe [3] failed. Expected: 17.000000  Observed: 0.000000
Probe [4] failed. Expected: 18.000000  Observed: 0.000000
Probe [6] failed. Expected: 12.000000  Observed: 0.000000
Probe [7] failed. Expected: 13.000000  Observed: 0.000000
Probe [9] failed. Expected: 12.000000  Observed: 0.000000
Probe [10] failed. Expected: 18.000000  Observed: 0.000000
Probe [12] failed. Expected: 27.000000  Observed: 0.000000
Probe [13] failed. Expected: 13.000000  Observed: 0.000000
Probe [15] failed. Expected: 27.000000  Observed: 0.000000
Probe [16] failed. Expected: 18.000000  Observed: 0.000000
Probe [18] failed. Expected: 22.000000  Observed: 0.000000
Probe [19] failed. Expected: 13.000000  Observed: 0.000000
Probe [21] failed. Expected: 22.000000  Observed: 0.000000
Probe [22] failed. Expected: 18.000000  Observed: 0.000000
Probe [24] failed. Expected: 37.000000  Observed: 0.000000
Probe [25] failed. Expected: 13.000000  Observed: 0.000000
Probe [27] failed. Expected: 37.000000  Observed: 0.000000
Probe [28] failed. Expected: 18.000000  Observed: 0.000000
Probe [30] failed. Expected: 32.000000  Observed: 0.000000
Probe [31] failed. Expected: 13.000000  Observed: 0.000000
Probe [33] failed. Expected: 32.000000  Observed: 0.000000
Probe [34] failed. Expected: 18.000000  Observed: 0.000000
Probe [36] failed. Expected: 47.000000  Observed: 0.000000
Probe [37] failed. Expected: 13.000000  Observed: 0.000000
Probe [39] failed. Expected: 47.000000  Observed: 0.000000
Probe [40] failed. Expected: 18.000000  Observed: 0.000000
Probe [42] failed. Expected: 42.000000  Observed: 0.000000
Probe [43] failed. Expected: 13.000000  Observed: 0.000000
Probe [45] failed. Expected: 42.000000  Observed: 0.000000
Probe [46] failed. Expected: 18.000000  Observed: 0.000000
glClientWaitSync returned GL_CONDITION_SATISFIED.
glClientWaitSync returned GL_CONDITION_SATISFIED.
glClientWaitSync returned GL_ALREADY_SIGNALED.

It also fails reliably on byt and g965.
Comment 1 Chris Wilson 2015-09-23 10:20:33 UTC
Kernel?
Comment 2 Mark Janes 2015-09-23 15:39:05 UTC
kernel is 4.2.0
Comment 3 Ben Widawsky 2015-10-07 23:18:55 UTC
I've reproduced this on Broadwell.
Comment 4 Mark Janes 2015-10-07 23:19:53 UTC
I withdraw the comment about g965/byt.  I can not reproduce failures on those platforms.

The test fails once in several thousand runs.
Comment 5 Mark Janes 2015-10-07 23:25:24 UTC
my mistake, the test does fail on BYT/g965.  I was looking for intermittent results from those platforms.
Comment 6 Mark Janes 2015-10-07 23:29:33 UTC
byt/g965 were fixed by 10c82c6c5fc415d323a5e9c6acdc6a4c85d6b712 for newer kernels.
Comment 7 Ben Widawsky 2015-10-28 14:48:20 UTC
*** Bug 92625 has been marked as a duplicate of this bug. ***
Comment 8 Denis 2018-11-22 13:47:55 UTC
looks like issue was fixed long time ago but wasn't closed

https://mesa-ci.01.org/mesa_master_daily/builds/4602/group/46728281c59ff6822e4cfcd51542697b

current runs show that test passes ok
Comment 9 Paul 2019-03-12 09:56:13 UTC
I've run test on Broadwell (Intel® HD Graphics 5500) with Ubuntu 18.04 and Kernel 5.0.1, Mesa 18.2.2 and latest master version (19.1.0).
Test successfully passed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.