Bug 9210 - mga glx rendering glitches
mga glx rendering glitches
Status: RESOLVED DUPLICATE of bug 10477
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/MGA
x86 (IA32) Linux (All)
: high normal
Assigned To: Default DRI bug account
Depends on:
  Show dependency treegraph
Reported: 2006-11-30 14:37 UTC by Michal Suchanek
Modified: 2009-08-24 12:25 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Note You need to log in before you can comment on or make changes to this bug.
Description Michal Suchanek 2006-11-30 14:37:09 UTC
I tried drm/mga/mesa head (as of Monday) because the one shipped with Ubuntu did
not work for me. It works quite well but I noticed a few glitches.

- the content of glxgears window appears a few pixels off wrt the window border
- garbage is rendered on the background of the mouse cursor square when it
enters the glxgears window
- the content of the window is not removed when the window is closed (ie it is
left on the desktop until there is repaint for some unrelated reason)
Comment 1 Tilman Sauerbeck 2006-12-02 13:51:58 UTC
Confirmed. It's a regression from Mesa 6.5.1.

I'll try to find out which commit introduce this bug.
Comment 2 Tilman Sauerbeck 2006-12-02 17:27:49 UTC
The breakage was introduced with commit
3a708ba57d470ba44937d45d378626ea2755c9ff (in krh's mesa.git), which was to fix
bug #8799.

Ian, can you have a look at this?
Comment 3 Tilman Sauerbeck 2006-12-06 12:36:26 UTC
It's b14bae846678b0d340af5b26c36e762817929d5d in the new official mesa git repo.
Comment 4 Tilman Sauerbeck 2007-04-09 05:14:15 UTC

*** This bug has been marked as a duplicate of bug 10477 ***
Comment 5 ajax at nwnk dot net 2009-08-24 12:25:23 UTC
Mass version move, cvs -> git