Bug 92113 - [HSW] Mesa 11.0, lots of failing UBO conformance tests
Summary: [HSW] Mesa 11.0, lots of failing UBO conformance tests
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: high major
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-25 11:37 UTC by Tapani Pälli
Modified: 2016-10-20 06:58 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tapani Pälli 2015-09-25 11:37:16 UTC
This seems somewhat random behaviour (not same tests are failing every time) but most of the time it's a lot of UBO tests.

As example these are failing tests on my HSW with 11.0 branch (cf71656).

--- 8< ---
ES3-CTS.shaders.uniform_block.single_basic_type.shared.lowp_float
ES3-CTS.shaders.uniform_block.single_basic_type.shared.mediump_uvec3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.lowp_uvec4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.column_major_highp_mat2
ES3-CTS.shaders.uniform_block.single_basic_type.shared.lowp_mat3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.mediump_mat3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.highp_mat3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_lowp_mat3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_mediump_mat3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_highp_mat3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.column_major_lowp_mat3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.column_major_mediump_mat3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.column_major_highp_mat3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.lowp_mat4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.highp_mat4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_lowp_mat4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_lowp_mat2x3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.lowp_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.mediump_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.highp_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_lowp_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_mediump_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_highp_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.column_major_lowp_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.column_major_mediump_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.column_major_highp_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.lowp_mat3x2
ES3-CTS.shaders.uniform_block.single_basic_type.shared.column_major_highp_mat3x2
ES3-CTS.shaders.uniform_block.single_basic_type.shared.lowp_mat3x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.mediump_mat3x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.highp_mat3x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.mediump_mat4x2
ES3-CTS.shaders.uniform_block.single_basic_type.shared.highp_mat4x2
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_lowp_mat4x2
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_mediump_mat4x2
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_highp_mat4x2
ES3-CTS.shaders.uniform_block.single_basic_type.shared.column_major_lowp_mat4x2
ES3-CTS.shaders.uniform_block.single_basic_type.shared.column_major_mediump_mat4x2
ES3-CTS.shaders.uniform_block.single_basic_type.shared.column_major_highp_mat4x2
ES3-CTS.shaders.uniform_block.single_basic_type.shared.lowp_mat4x3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.mediump_mat4x3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.highp_mat4x3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_lowp_mat4x3
ES3-CTS.shaders.uniform_block.single_basic_type.packed.mediump_float
ES3-CTS.shaders.uniform_block.single_basic_type.packed.highp_ivec2
ES3-CTS.shaders.uniform_block.single_basic_type.packed.lowp_mat3
ES3-CTS.shaders.uniform_block.single_basic_type.packed.mediump_mat3
ES3-CTS.shaders.uniform_block.single_basic_type.packed.row_major_lowp_mat3
ES3-CTS.shaders.uniform_block.single_basic_type.packed.lowp_mat2x3
ES3-CTS.shaders.uniform_block.single_basic_type.packed.mediump_mat2x3
ES3-CTS.shaders.uniform_block.single_basic_type.packed.row_major_lowp_mat2x3
ES3-CTS.shaders.uniform_block.single_basic_type.packed.row_major_mediump_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.packed.row_major_highp_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.packed.column_major_mediump_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.packed.row_major_lowp_mat3x4
ES3-CTS.shaders.uniform_block.single_basic_type.packed.lowp_mat4x2
ES3-CTS.shaders.uniform_block.single_basic_type.packed.mediump_mat4x3
ES3-CTS.shaders.uniform_block.single_basic_type.packed.highp_mat4x3
ES3-CTS.shaders.uniform_block.single_basic_type.packed.row_major_lowp_mat4x3
ES3-CTS.shaders.uniform_block.single_basic_type.packed.row_major_mediump_mat4x3
ES3-CTS.shaders.uniform_block.single_basic_type.packed.column_major_lowp_mat4x3
ES3-CTS.shaders.uniform_block.single_basic_type.std140.mediump_vec3
ES3-CTS.shaders.uniform_block.single_basic_type.std140.lowp_vec4
ES3-CTS.shaders.uniform_block.single_basic_type.std140.lowp_mat2
ES3-CTS.shaders.uniform_block.single_basic_type.std140.mediump_mat2
ES3-CTS.shaders.uniform_block.single_basic_type.std140.row_major_lowp_mat2
ES3-CTS.shaders.uniform_block.single_basic_type.std140.row_major_highp_mat3
ES3-CTS.shaders.uniform_block.single_basic_type.std140.column_major_mediump_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.std140.row_major_lowp_mat3x4
ES3-CTS.shaders.uniform_block.single_basic_type.std140.row_major_highp_mat3x4
ES3-CTS.shaders.uniform_block.single_basic_type.std140.mediump_mat4x3
ES3-CTS.shaders.uniform_block.single_basic_type.std140.row_major_lowp_mat4x3
ES3-CTS.shaders.uniform_block.single_basic_array.shared.ivec3
ES3-CTS.shaders.uniform_block.single_basic_array.shared.uvec3
ES3-CTS.shaders.uniform_block.single_basic_array.shared.uvec4
ES3-CTS.shaders.uniform_block.single_basic_array.shared.bvec2
ES3-CTS.shaders.uniform_block.single_basic_array.packed.vec4
ES3-CTS.shaders.uniform_block.single_basic_array.packed.bvec2
ES3-CTS.shaders.uniform_block.single_basic_array.packed.bvec4
ES3-CTS.shaders.uniform_block.single_basic_array.std140.vec4
ES3-CTS.shaders.uniform_block.single_basic_array.std140.ivec3
ES3-CTS.shaders.uniform_block.instance_array_basic_type.shared.ivec2
ES3-CTS.shaders.uniform_block.instance_array_basic_type.packed.vec3
ES3-CTS.shaders.uniform_block.instance_array_basic_type.std140.ivec2
ES3-CTS.shaders.uniform_block.random.scalar_types.7
ES3-CTS.shaders.uniform_block.random.vector_types.1
Comment 1 Tapani Pälli 2015-10-06 07:30:02 UTC
With Mesa master there are fewer errors, as example following results this morning Mesa (64831832791139328a67b80387f062d39e304d24)

--- 8< ---
ES3-CTS.shaders.uniform_block.single_basic_type.shared.highp_uvec4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.highp_mat3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_lowp_mat3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_mediump_mat3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_highp_mat3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_mediump_mat4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_lowp_mat2x3
ES3-CTS.shaders.uniform_block.single_basic_type.shared.highp_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_lowp_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_mediump_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.row_major_highp_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.column_major_lowp_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.column_major_mediump_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.column_major_highp_mat2x4
ES3-CTS.shaders.uniform_block.single_basic_type.shared.mediump_mat3x2
ES3-CTS.shaders.uniform_block.single_basic_type.shared.column_major_mediump_mat4x2
ES3-CTS.shaders.uniform_block.single_basic_type.packed.highp_float
ES3-CTS.shaders.uniform_block.single_basic_type.packed.highp_mat4
ES3-CTS.shaders.uniform_block.single_basic_type.packed.lowp_mat2x3
ES3-CTS.shaders.uniform_block.single_basic_type.std140.row_major_mediump_mat2x3
ES3-CTS.shaders.uniform_block.single_basic_array.shared.ivec2
ES3-CTS.shaders.uniform_block.single_basic_array.packed.vec3
ES3-CTS.shaders.uniform_block.single_basic_array.std140.ivec2
ES3-CTS.shaders.uniform_block.instance_array_basic_type.shared.vec2
ES3-CTS.shaders.uniform_block.instance_array_basic_type.shared.ivec2
ES3-CTS.shaders.uniform_block.instance_array_basic_type.shared.ivec4
ES3-CTS.shaders.uniform_block.instance_array_basic_type.packed.vec3
ES3-CTS.shaders.uniform_block.instance_array_basic_type.std140.vec2
ES3-CTS.shaders.uniform_block.instance_array_basic_type.std140.ivec2
ES3-CTS.shaders.uniform_block.random.scalar_types.6
ES3-CTS.shaders.uniform_block.random.scalar_types.9
Comment 2 Eduardo Lima Mitev 2016-02-17 10:18:48 UTC
On my HSW laptop I cannot reproduce any of these fails. I get 100% pass ratio for ES3-CTS.shaders.uniform_block.*

I'm using CTS 3.1.1.0 though. Should this be tested specifically with CTS-3.0 (e.g ESCTS-3.0.4.0) to reproduce the fails? Otherwise, I think this can be close as already-fixed.
Comment 3 Tapani Pälli 2016-02-17 10:24:08 UTC
(In reply to Eduardo Lima Mitev from comment #2)
> On my HSW laptop I cannot reproduce any of these fails. I get 100% pass
> ratio for ES3-CTS.shaders.uniform_block.*
> 
> I'm using CTS 3.1.1.0 though. Should this be tested specifically with
> CTS-3.0 (e.g ESCTS-3.0.4.0) to reproduce the fails? Otherwise, I think this
> can be close as already-fixed.

individually they pass but if you run the whole ES3 tests like this:

./glcts --deqp-case=ES3-CTS*

then they fail.
Comment 4 Eduardo Lima Mitev 2016-02-17 10:42:10 UTC
(In reply to Tapani Pälli from comment #3)
> (In reply to Eduardo Lima Mitev from comment #2)
> > On my HSW laptop I cannot reproduce any of these fails. I get 100% pass
> > ratio for ES3-CTS.shaders.uniform_block.*
> > 
> > I'm using CTS 3.1.1.0 though. Should this be tested specifically with
> > CTS-3.0 (e.g ESCTS-3.0.4.0) to reproduce the fails? Otherwise, I think this
> > can be close as already-fixed.
> 
> individually they pass but if you run the whole ES3 tests like this:
> 
> ./glcts --deqp-case=ES3-CTS*
> 
> then they fail.

Just tried that, and I get this:

Test run totals:
  Passed:        2996/2997 (99.97%)
  Failed:        0/2997 (0.00%)
  Not supported: 1/2997 (0.03%)
  Warnings:      0/2997 (0.00%)

This was with mesa HEAD git~edf774b (master from this morning), ESCTS-3.1.1.0, on my HSW laptop.
Comment 5 Tapani Pälli 2016-02-17 10:49:10 UTC
(In reply to Eduardo Lima Mitev from comment #4)
> (In reply to Tapani Pälli from comment #3)
> > (In reply to Eduardo Lima Mitev from comment #2)
> > > On my HSW laptop I cannot reproduce any of these fails. I get 100% pass
> > > ratio for ES3-CTS.shaders.uniform_block.*
> > > 
> > > I'm using CTS 3.1.1.0 though. Should this be tested specifically with
> > > CTS-3.0 (e.g ESCTS-3.0.4.0) to reproduce the fails? Otherwise, I think this
> > > can be close as already-fixed.
> > 
> > individually they pass but if you run the whole ES3 tests like this:
> > 
> > ./glcts --deqp-case=ES3-CTS*
> > 
> > then they fail.
> 
> Just tried that, and I get this:
> 
> Test run totals:
>   Passed:        2996/2997 (99.97%)
>   Failed:        0/2997 (0.00%)
>   Not supported: 1/2997 (0.03%)
>   Warnings:      0/2997 (0.00%)
> 
> This was with mesa HEAD git~edf774b (master from this morning),
> ESCTS-3.1.1.0, on my HSW laptop.

I'm running on same Mesa, CTS is a snapshot (not master but should not be very old) from gitlab and says 'GL-CTS-2.0' as releaseName. I have 2887 passing, 109 failing (all of these ubo tests) and 1 not supported. This is Haswell desktop GT2 (0x0412).
Comment 6 Tapani Pälli 2016-02-17 10:50:57 UTC
(In reply to Tapani Pälli from comment #5)
> (In reply to Eduardo Lima Mitev from comment #4)
> > (In reply to Tapani Pälli from comment #3)
> > > (In reply to Eduardo Lima Mitev from comment #2)
> > > > On my HSW laptop I cannot reproduce any of these fails. I get 100% pass
> > > > ratio for ES3-CTS.shaders.uniform_block.*
> > > > 
> > > > I'm using CTS 3.1.1.0 though. Should this be tested specifically with
> > > > CTS-3.0 (e.g ESCTS-3.0.4.0) to reproduce the fails? Otherwise, I think this
> > > > can be close as already-fixed.
> > > 
> > > individually they pass but if you run the whole ES3 tests like this:
> > > 
> > > ./glcts --deqp-case=ES3-CTS*
> > > 
> > > then they fail.
> > 
> > Just tried that, and I get this:
> > 
> > Test run totals:
> >   Passed:        2996/2997 (99.97%)
> >   Failed:        0/2997 (0.00%)
> >   Not supported: 1/2997 (0.03%)
> >   Warnings:      0/2997 (0.00%)
> > 
> > This was with mesa HEAD git~edf774b (master from this morning),
> > ESCTS-3.1.1.0, on my HSW laptop.
> 
> I'm running on same Mesa, CTS is a snapshot (not master but should not be
> very old) from gitlab and says 'GL-CTS-2.0' as releaseName. I have 2887
> passing, 109 failing (all of these ubo tests) and 1 not supported. This is
> Haswell desktop GT2 (0x0412).

This CTS snapshot is from last September and has a set of internal patches to enable using gbm + Intel support for image external extension.
Comment 7 Tapani Pälli 2016-10-20 06:58:21 UTC
I'm resolving this as WORKSFORME as I cannot reproduce this anymore. There are numerous ES3-CTS tests failing for HSW but these ones are passing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.