Bug 92261 - SIGSEGV in weston_surface_destroy
Summary: SIGSEGV in weston_surface_destroy
Status: RESOLVED MOVED
Alias: None
Product: Wayland
Classification: Unclassified
Component: weston (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Wayland bug list
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-02 20:11 UTC by Benoit Gschwind
Modified: 2018-06-08 23:54 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
gdb back trace (1.18 KB, text/plain)
2015-10-02 20:11 UTC, Benoit Gschwind
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Benoit Gschwind 2015-10-02 20:11:21 UTC
Created attachment 118638 [details]
gdb back trace

Hello,

When I run my ugly Xwmland (a regular wayland client) and kill it, weston generate segfault. I do not figure out the source, I attached the trace I gathered with gdb when this segfault occurred.

Best regards
Comment 1 Daniel Stone 2018-06-04 09:05:02 UTC
Are you able to run this under Valgrind, if it's still reproducible?
Comment 2 GitLab Migration User 2018-06-08 23:54:05 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/wayland/weston/issues/68.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.