Bug 92374 - [HSW dEQP] dEQP-GLES2.functional.fbo.render.recreate_colorbuffer are failing some subtests
Summary: [HSW dEQP] dEQP-GLES2.functional.fbo.render.recreate_colorbuffer are failing ...
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 11.0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-09 19:35 UTC by Elio
Modified: 2016-03-26 09:49 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Dmesg logs (124.14 KB, text/plain)
2015-10-09 19:35 UTC, Elio
Details
Terminal Output (6.93 KB, text/plain)
2015-10-09 19:35 UTC, Elio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elio 2015-10-09 19:35:02 UTC
Created attachment 118789 [details]
Dmesg logs

The following test cases are failing from functional@fbo@render@recreate_buffer:

<%
deqp-gles2@functional@fbo@render@recreate_colorbuffer@no_rebind_tex2d_rgb
deqp-gles2@functional@fbo@render@recreate_colorbuffer@no_rebind_tex2d_rgba
deqp-gles2@functional@fbo@render@recreate_colorbuffer@no_rebind_tex2d_rgba_depth_component16
deqp-gles2@functional@fbo@render@recreate_colorbuffer@no_rebind_tex2d_rgba_stencil_index8
deqp-gles2@functional@fbo@render@recreate_colorbuffer@no_rebind_tex2d_rgb_depth_component16
deqp-gles2@functional@fbo@render@recreate_colorbuffer@no_rebind_tex2d_rgb_stencil_index8
%>

Test Enviroment:

kernel: 4.3.0
Mesa: (11.2)git-
Xf86_video_intel:2.99.917
Libdrm:libdrm-2.4.65
Libva: 1.6.1
vaapi-in tel-driver: 1.6.1
Cairo: 1.14.2
Xserver: xorg-server-latests

Hardware:

Hardware
Platform: Intel NUC D54250WYK
Processor Intel Core I5-425OU 1.30 GHz
Software
Linux distribution: Ubuntu 14.04 LTS 64Bits
BIOS: WTLPT10H.86A.0021.2013.1.017.1606

Steps to reproduce:
Install Graphic stack with configuration mentioned before.
Install deqp tool.
Execute: sudo ./deqp-gles2 --deqp-case=dEQP-GLES2.functional.fbo.render.recreate_buffer.*

Expected Result: Test should pass without crash/error
Actual results: The mentioned test cases are failing

Please check attached logs
Comment 1 Elio 2015-10-09 19:35:42 UTC
Created attachment 118790 [details]
Terminal Output
Comment 2 Matt Turner 2015-10-09 19:47:28 UTC
Please file i965 bugs against Component: Drivers/DRI/i965. You can use this link directly: https://bugs.freedesktop.org/enter_bug.cgi?product=Mesa&component=Drivers/DRI/i965
Comment 3 Antia Puentes 2015-10-13 13:22:37 UTC
I will be looking at this one.
Comment 4 Ian Romanick 2015-10-13 19:47:44 UTC
(In reply to Antia Puentes from comment #3)
> I will be looking at this one.

Great.  If you're going to take a bug, make yourself the assignee, and change the status to assigned.  Thanks.
Comment 5 Humberto Israel Perez Rodriguez 2015-10-22 16:40:22 UTC
This test keeps failing on HSW with the following configuration :

kernel: 4.3.0-rc5-drm-intel-nightly+
xorg-server-1.17.2
libdrm-2.4.65
xf86-video-intel-2.99.917
mesa-11.1.0-devel (git 6f39546)
libva-1.6.1
intel-driver-1.6.1
cairo-1.14.2
Comment 6 Jairo Miramontes 2015-10-23 02:33:47 UTC
Same tests failed on BYT  on the following config:

kernel: 4.3.0-rc5-drm-intel-nightly
xorg-server-1.17.2
libdrm-2.4.65
xf86-video-intel-2.99.917
mesa-11.1.0-devel (git 6f39546)
libva-1.6.1
intel-driver-1.6.1
cairo-1.14.2
Comment 7 Iago Toral 2015-10-29 11:40:40 UTC
All these tests pass for me in Haswell with current master:

$ ./deqp-gles2 -n dEQP-GLES2.functional.fbo.render.recreate*

(...)

Test run totals:
  Passed:        80/80 (100.0%)
  Failed:        0/80 (0.0%)
  Not supported: 0/80 (0.0%)
  Warnings:      0/80 (0.0%)
Comment 8 Iago Toral 2015-10-29 11:55:22 UTC
Also, it seems that in the traces attached to the bug report, you also get some tests marked as "Unsupported", that's weird, since I see all of them passing and I am also running this on Haswell.

BTW, "steps to reproduce" is wrong, it says:

./deqp-gles2 --deqp-case=dEQP-GLES2.functional.fbo.render.recreate_buffer.*

when it should say:

./deqp-gles2 --deqp-case=dEQP-GLES2.functional.fbo.render.recreate_colorbuffer.*
Comment 9 Iago Toral 2015-10-29 12:26:13 UTC
(In reply to Iago Toral from comment #7)
> All these tests pass for me in Haswell with current master:
> 
> $ ./deqp-gles2 -n dEQP-GLES2.functional.fbo.render.recreate*
> 
> (...)
> 
> Test run totals:
>   Passed:        80/80 (100.0%)
>   Failed:        0/80 (0.0%)
>   Not supported: 0/80 (0.0%)
>   Warnings:      0/80 (0.0%)

Actually, I was testing against the wrong installation. Here are the results for mesa master:

Test run totals:
  Passed:        50/80 (62.5%)
  Failed:        0/80 (0.0%)
  Not supported: 30/80 (37.5%)
  Warnings:      0/80 (0.0%)

So still no failures.
Comment 10 Tapani Pälli 2015-11-03 09:26:23 UTC
No failures for me either.

I noticed that description has 'sudo' in the command line, why is this? Note that when you run under sudo you will run with different environment than current user unless you use '-E' parameter. Please make sure you run test against correct Mesa.
Comment 11 Kenneth Graunke 2016-03-26 09:49:37 UTC
Marking as Resolved/Worksforme because these tests pass for me, Iago, and Tapani.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.