Bug 92432 - GPU HANG: ecode 6:0:0x00675c57, in Xorg [1341], reason: Ring hung, action: reset
Summary: GPU HANG: ecode 6:0:0x00675c57, in Xorg [1341], reason: Ring hung, action: reset
Status: CLOSED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-11 18:50 UTC by ukwt
Modified: 2017-04-11 12:25 UTC (History)
1 user (show)

See Also:
i915 platform: SNB
i915 features: GPU hang


Attachments
GPU crash dump from /sys/class/drm/card0/error (75.99 KB, text/plain)
2015-10-11 18:50 UTC, ukwt
Details
GPU crash dump from /sys/class/drm/card0/error (XZ archive) (75.99 KB, application/octet-stream)
2015-10-11 18:53 UTC, ukwt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ukwt 2015-10-11 18:50:26 UTC
Created attachment 118825 [details]
GPU crash dump from /sys/class/drm/card0/error

I was watching video in mpv player in fullscreen mode. When I tried to switch the player to windowed mode, video playback seemed to have stopped, although sound continued to play. After a couple seconds the screen blinked and system has returned to normal operation.

Here is what I have found in dmesg output:

[Oct12 00:30] [drm] stuck on render ring
[  +0.000844] [drm] GPU HANG: ecode 6:0:0x00675c57, in Xorg [1341], reason: Ring hung, action: reset
[  +0.000003] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[  +0.000001] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[  +0.000001] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[  +0.000001] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[  +0.000001] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[  +0.007142] drm/i915: Resetting chip after gpu hang

-------------------------------------------------------

My CPU is Pentium B970 (Intel HD2000).
OS: Ubuntu 15.04 fully updated.
Kernel: 3.19.0-30.
Mesa: 10.5.9-2.
Comment 1 ukwt 2015-10-11 18:53:51 UTC
Created attachment 118826 [details]
GPU crash dump from /sys/class/drm/card0/error (XZ archive)

I have no idea why Bugzilla has turned a xz archive into plain text file.
Reuploading as a valid archive.
Comment 2 yann 2017-03-16 13:07:33 UTC
(In reply to ukwt from comment #1)
> Created attachment 118826 [details]
> GPU crash dump from /sys/class/drm/card0/error (XZ archive)
> 
> I have no idea why Bugzilla has turned a xz archive into plain text file.
> Reuploading as a valid archive.

We seem to have neglected the bug a bit, apologies.

ukwt@ya.ru, since There were improvements pushed in kernel & xf86-video-intel that will benefit to your system, so please re-test with latest kernel & xf86-video-intel -alternatively you may use modesetting/glamor with latest mesa version- and mark as REOPENED if you can reproduce (and attach fresh gpu error dump & kernel log) and RESOLVED/* if you cannot reproduce.
Comment 3 Chris Wilson 2017-04-08 19:54:14 UTC
Batch buffer corruption (looks like the invalid memset), likely fixed by an update to mesa.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.