Bug 92495 - Freeze/black screen on DPM/after changing power_profile
Summary: Freeze/black screen on DPM/after changing power_profile
Status: RESOLVED DUPLICATE of bug 91880
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-16 12:18 UTC by John Frei
Modified: 2015-10-16 15:01 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
vram bios (65.00 KB, text/plain)
2015-10-16 12:18 UTC, John Frei
no flags Details
dmesg with dpm=0 (89.18 KB, text/plain)
2015-10-16 12:19 UTC, John Frei
no flags Details
Xorg log (93.30 KB, text/plain)
2015-10-16 12:20 UTC, John Frei
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Frei 2015-10-16 12:18:32 UTC
Created attachment 118918 [details]
vram bios

I'm using an R9 390 (PowerColor Radeon R9 390 PCS+) on Fedora 22.

If I try to use DPM with the kernel parameter dpm=1, I get a black screen/freeze after the login on GDM.
So I tried to disable DPM, which worked for me to use the computer for basic work, but the 3D performance is very poor (even slower than my good old HD 5770).
Everytime I want to change the power_profile to high, I get an instant black screen/freeze, too.
Then I cannot do anything anymore (CTRL+ALT+F1/F2... does not work).

Is it a bug in the power management/reclocking code?!?

R9 390 on radeonsi
Mesa 11.1 (<-- Problem also exists on Mesa 10.6)
Fedora 22 x86_64
Comment 1 John Frei 2015-10-16 12:19:18 UTC
Created attachment 118919 [details]
dmesg with dpm=0
Comment 2 John Frei 2015-10-16 12:20:03 UTC
Created attachment 118920 [details]
Xorg log
Comment 3 John Frei 2015-10-16 12:21:46 UTC
I'm not sure if it is the same bug as Bug 91880.
https://bugs.freedesktop.org/show_bug.cgi?id=91880
Comment 4 John Frei 2015-10-16 12:45:25 UTC
Things I forgot to mention:
The card works like a charm on Windows.
Setting the power_profile to low/mid doesn't trigger the crash.

If the crash was triggered, I can't connect to the ssh daemon via an remote device.
Comment 5 Alex Deucher 2015-10-16 15:01:33 UTC

*** This bug has been marked as a duplicate of bug 91880 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.