Bug 92648 - semi-stuck H/h XQuartz
Summary: semi-stuck H/h XQuartz
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/DDX/XQuartz (show other bugs)
Version: unspecified
Hardware: All All
: medium normal
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
URL: http://xquartz.macosforge.org/trac/ti...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-23 17:44 UTC by John Doty
Modified: 2016-05-29 21:08 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Doty 2015-10-23 17:44:46 UTC
reposted from http://xquartz.macosforge.org/trac/ticket/443

Changed 3 years ago by jpd@…

Replying to jeremyhu@…:
I still have never seen this issue, and I have 'Enable key equivalents under X11' checked. Regarding debug logging, check out the "LOGGING" section of the Xquartz man page.
Here's a procedure that reliably induces the problem for me (with 'Enable key equivalents under X11' checked):
Close all X11 windows, but leave XQuartz running.
command-N      (open terminal)
command-H      (hide XQuartz)
Click XQuartz icon to unhide
Click terminal window to focus
shift-H
I see something like HHHhhhhhhhhhhh.... every time.
comment:13 follow-up: ↓ 15 Changed 3 years ago by jeremyhu@…

Ok, so it's almost certainly fallout from the CMD-H ... interesting... I've reproduced that case.
I still haven't seen it happen randomly though.
comment:14 Changed 3 years ago by jeremyhu@…

Milestone set to 2.7.4
comment:15 in reply to: ↑ 13 Changed 3 years ago by jpd@…

Replying to jeremyhu@…:
Ok, so it's almost certainly fallout from the CMD-H ... interesting... I've reproduced that case.
I still haven't seen it happen randomly though.
It seems to happen on the first 'h' or 'H' after CMD-H. That might, of course, be long after, thus appearing to be random.
Comment 1 SciFi 2015-10-30 05:30:32 UTC
Just wanted to acknowledge the movement of this bug from the macosforge trac to this place, and for me to sign-up here to continue tracking it.  FWIW this still occurs with the current release of XQuartz 2.7.8.  ;)
Comment 2 henrik 2016-05-23 13:26:47 UTC
Random fast repeat of 'h' under XQuartz occurs for me almost daily, and has been
doing so for years.  It's not critical, but annoying and bothersome, and a fix
would be much appreciated.  I'm currently on XQuartz 2.7.8 (xorg-server 1.16.4).

If I can assist in any way in getting this bug eradicated, I'd be happy to do so.
Comment 3 Jeremy Huddleston Sequoia 2016-05-29 20:56:40 UTC
The issue has to do with the logic to ignore certain key up events for ignored key down events.  For instance, if you do shift-cmd-3 to take a screenshot, when you hit the 3, we know that the event is going to be handled by AppKit, so we remember to not pass along the subsequent up event to X11 when it comes in.

The problem is that the action of the cmd-h changes our state in a way that causes us to not even consider its up, so we end up ignoring the next h up event which was actually valid.
Comment 4 Jeremy Huddleston Sequoia 2016-05-29 21:08:45 UTC
https://github.com/XQuartz/xorg-server/commit/f598e886fab18722fc390d15672adcd7ab8a5833

Should be addressed in XQuartz 2.7.10_beta2 (not yet available).


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.