Bug 92656 - focus-related regression in XQuartz 2.7.3 on OSX <10.9
Summary: focus-related regression in XQuartz 2.7.3 on OSX <10.9
Status: RESOLVED MOVED
Alias: None
Product: XQuartz
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 2.7.3 (xserver-1.12.4)
Hardware: Other All
: medium normal
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
URL: https://xquartz.macosforge.org/trac/t...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-23 20:42 UTC by Marc Bejarano
Modified: 2019-05-23 18:30 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
screen capture showing issue (748.24 KB, application/octet-stream)
2015-10-23 20:47 UTC, Marc Bejarano
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Bejarano 2015-10-23 20:42:46 UTC
migrated from trac ticket 636 opened Sep 6, 2012:
--
ever since upgrading from 2.7.2 to 2.7.3, i now see X11.app stop bringing it's windows to the foreground when switching back to it. this doesn't happen immediately. if i restart X11.app, things work for a while, but then eventually break. once broken, the bad behavior is reproducible every time. i only run one X application (Visual SlickEdit). using the <CMD>-2 keyboard shortcut will bring the window back to the foreground. sometimes, like right now, that won't even work and i'll need to minimize the window and i'll need to use Window -> Bring All to Front to get it to come back up.
--
another data point: exiting and restarting the X application is another way to work around the problem (presumably temporarily)
--
i haven't seen the issue since upgrading the OS to 10.9. i'd be surprised if the underlying bug weren't still there, but i'm thrilled that it's no longer manifesting in the way it was. i'm currently using XQuartz 2.7.5 with OSX 10.9.2.
Comment 1 Marc Bejarano 2015-10-23 20:47:57 UTC
Created attachment 119161 [details]
screen capture showing issue
Comment 2 GitLab Migration User 2019-05-23 18:30:30 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/757.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.