Bug 92824 - [regression, bisected] `make check` dispatch-sanity broken by GL_EXT_buffer_storage
Summary: [regression, bisected] `make check` dispatch-sanity broken by GL_EXT_buffer_s...
Status: CLOSED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ilia Mirkin
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-04 19:09 UTC by Mark Janes
Modified: 2015-11-04 20:01 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2015-11-04 19:09:15 UTC
dispatch sanity fails with this commit:

13b19aa815661cd17b74c8694b6c466bfaf75740
Author:     Ryan Houdek <sonicadvance1@gmail.com>
AuthorDate: Mon Nov 2 19:30:18 2015 -0600
Commit:     Ilia Mirkin <imirkin@alum.mit.edu>
CommitDate: Wed Nov 4 00:01:03 2015 -0500

    mesa: expose support for GL_EXT_buffer_storage
    
    This extension requires ES 3.1 since it relies on glMemoryBarrier.
    For testing purposes I temporarily moved glMemoryBarrier to be an ES 3.0
    function.
    This has been tested with the piglit in the ML and the Dolphin emulator.
    
    Reviewed-by: Ilia Mirkin <imirkin@alum.mit.edu>

/mnt/space/jenkins/jobs/Leeroy/workspace/repos/mesa/src/mesa/main/tests/dispatch_sanity.cpp:173
Value of: table[i]
  Actual: 0x818ea50
Expected: nop_table[i]
Which is: 0x805c380
i = 902 (BufferStorage)
Comment 1 Mark Janes 2015-11-04 19:11:24 UTC
Assigning to Ilia, since I can't find an account for Ryan Houdek on fdo.
Comment 2 Ilia Mirkin 2015-11-04 19:32:20 UTC
Should be fixed by

commit 5bbd522452cfe86fc600203fe1a9b056582e2000
Author: Ilia Mirkin <imirkin@alum.mit.edu>
Date:   Wed Nov 4 14:26:37 2015 -0500

    mesa/tests: add glBufferStorageEXT to ES 3.1 dispatch list
    
    I thought that aliased functions didn't need to be added, but that might
    only be if the function aliases something in the same {desktop,ES}
    space. Resolves the dispatch sanity test failure.
    
    Fixes: 13b19aa81 (mesa: expose support for GL_EXT_buffer_storage)
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=92824
    Signed-off-by: Ilia Mirkin <imirkin@alum.mit.edu>

Sorry, I should have run 'make check' before pushing the original out... forgot.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.