Bug 92825 - Eclipse glitches while scrolling text
Summary: Eclipse glitches while scrolling text
Status: NEW
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium minor
Assignee: Chris Wilson
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-04 19:26 UTC by Germano Massullo
Modified: 2015-11-10 09:31 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (23.48 KB, text/plain)
2015-11-04 22:11 UTC, Germano Massullo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Germano Massullo 2015-11-04 19:26:43 UTC
Upstream bugreport of https://bugzilla.redhat.com/show_bug.cgi?id=1278153


Description of problem:
Eclipse Mars editor has many glitchies while scrolling the code.
See video https://www.youtube.com/watch?v=HNQueK4sA54

Version-Release number of selected component (if applicable):
lspci -k | grep -iA 3 vga
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
        Subsystem: Lenovo ThinkPad R60/T60/X60 series
        Kernel driver in use: i915
        Kernel modules: i915
Comment 1 Germano Massullo 2015-11-04 19:29:57 UTC
Eclipse bugreport https://bugs.eclipse.org/bugs/show_bug.cgi?id=481444
Comment 2 Chris Wilson 2015-11-04 20:49:41 UTC
Please attach your Xorg.log.
Comment 3 Germano Massullo 2015-11-04 22:11:42 UTC
Created attachment 119416 [details]
Xorg.0.log
Comment 4 Chris Wilson 2015-11-10 09:16:14 UTC
I've fired up my trusty Pineview and installed eclipse, but I've been distracted in running kernel tests on it for the past couple of weeks. The major thing to make sure I have roughly the right environment to test is what display/compositing manager are you using, with what settings? Would I be able to reproduce this by scrolling any window in eclipse or does it take a certain configuration?
Comment 5 Robert Roth 2015-11-10 09:31:01 UTC
I am using Fedora 23 with almost stock GNOME shell, using mutter as compositiing manager (as far as I know). I am able to reproduce the issue on multiple computers, with no special eclipse setup, default configuration (as downloaded from the eclipse website), and opening and scrolling a long file in an editor.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.