Bug 92856 - Logitech G600 mouse pointer issue
Summary: Logitech G600 mouse pointer issue
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/evdev (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Peter Hutterer
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-07 13:33 UTC by Gabriel Cavallo
Modified: 2015-11-12 20:53 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Logitech G600 event0 recording (2.71 KB, text/plain)
2015-11-09 16:09 UTC, Gabriel Cavallo
no flags Details
Logitech G600 event1 recording (10.56 KB, text/plain)
2015-11-09 16:09 UTC, Gabriel Cavallo
no flags Details
libinput settings (3.43 KB, text/plain)
2015-11-09 16:10 UTC, Gabriel Cavallo
no flags Details
list device (813 bytes, text/plain)
2015-11-09 16:14 UTC, Gabriel Cavallo
no flags Details
0001-Only-map-x-and-y-to-axes-0-and-1.patch (1.82 KB, patch)
2015-11-10 04:48 UTC, Peter Hutterer
no flags Details | Splinter Review
xorg logs (11.92 KB, text/plain)
2015-11-10 12:15 UTC, Gabriel Cavallo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Cavallo 2015-11-07 13:33:26 UTC
https://bugs.archlinux.org/task/46994

Using evdev 2.10.0 and xorg-server 1.17.4

Mouse clicks makes my mouse move half way across my screen with my Logitech G600. This makes the cursor pretty much unusable. My other mouse (MX570 trackball) worked fine. Sadly all my xorg logs got replaced by trying to fix the issue.

Only fix I could find is to downgrade to evdev 2.9.2 and xorg-server 1.17.3
Comment 1 Peter Hutterer 2015-11-08 21:20:19 UTC
http://wayland.freedesktop.org/libinput/doc/latest/reporting_bugs.html

look through this page please and attach the information required. If you don't have libinput, just stick to the evemu bits.
Comment 2 Gabriel Cavallo 2015-11-09 16:09:00 UTC
Created attachment 119514 [details]
Logitech G600 event0 recording
Comment 3 Gabriel Cavallo 2015-11-09 16:09:29 UTC
Created attachment 119515 [details]
Logitech G600 event1 recording
Comment 4 Gabriel Cavallo 2015-11-09 16:10:45 UTC
Created attachment 119516 [details]
libinput settings
Comment 5 Gabriel Cavallo 2015-11-09 16:14:25 UTC
Created attachment 119517 [details]
list device
Comment 6 Gabriel Cavallo 2015-11-09 16:26:05 UTC
Comment on attachment 119515 [details]
Logitech G600 event1 recording

event1 evemu reproduces issue on evdev 2.10.0 but not on evdev 2.9.2
Comment 7 Peter Hutterer 2015-11-10 04:48:23 UTC
Created attachment 119527 [details] [review]
0001-Only-map-x-and-y-to-axes-0-and-1.patch

Give this one a try please
Comment 8 Gabriel Cavallo 2015-11-10 12:15:05 UTC
Created attachment 119539 [details]
xorg logs

It compiles just fine but I can't for the life of me get it to recognize any of my input devices... I'm probably missing some config?

Anyways I've attached xorg logs for all tested versions that may help.
Comment 9 Peter Hutterer 2015-11-10 21:29:18 UTC
did you remove the distribution-provided evdev driver? Looks like this file is missing: http://cgit.freedesktop.org/xorg/driver/xf86-input-evdev/tree/10-evdev.conf
put that in /etc/X11/xorg.conf.d and restart the server and that should be it. Once you switch back to the distribution package, you can drop the file again.
Comment 10 Gabriel Cavallo 2015-11-11 16:51:59 UTC
Oh I didn't figure it installs in /usr/local instead!
The patch actually does work! I tested every buttons and the patch fixes the cursor issue on all buttons.

As a side note I think the Makefile does not find the xorg.conf directory for me so I indeed needed to copy it over manually:

 /usr/bin/mkdir -p 'NONE/share/X11/xorg.conf.d'
 /usr/bin/install -c -m 644 10-evdev.conf 'NONE/share/X11/xorg.conf.d'

I'll keep the patch running for a few days let me know if you need more info.
Comment 11 Peter Hutterer 2015-11-12 20:53:05 UTC
pushed it now, let me know if you find any problems with it though. Thanks.

commit d7e61a7074b802b49f57549530b289bbaa0a4855
Author: Peter Hutterer <peter.hutterer@who-t.net>
Date:   Tue Nov 10 14:35:51 2015 +1000

    Only map x and y to axes 0 and 1


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.