Bug 92952 - Enabling Anti-Aliasing, when pp_jimenezmlaa and pp_jimenezmlaa_color are set, causes screen to corrupt
Summary: Enabling Anti-Aliasing, when pp_jimenezmlaa and pp_jimenezmlaa_color are set,...
Status: RESOLVED NOTABUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: Other All
: medium major
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-14 18:25 UTC by EoD
Modified: 2015-11-19 20:16 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
glxinfo (97.52 KB, text/plain)
2015-11-14 18:25 UTC, EoD
Details

Note You need to log in before you can comment on or make changes to this bug.
Description EoD 2015-11-14 18:25:46 UTC
Created attachment 119662 [details]
glxinfo

When I start swkotor.exe via wine and I enable AA I get a totally corrupted screen: http://imgur.com/95HHd6v 
and after alt-tabbing: http://imgur.com/QzqGJfA


Here is an apitrace: https://drive.google.com/file/d/0B42CQY2wGHumalllYjVqQ1NJSEk/view?usp=sharing
Comment 1 Ilia Mirkin 2015-11-14 18:32:36 UTC
Seems to replay ok on nvc0 and nv50 with mesa 11.0.4 and master.
Comment 2 EoD 2015-11-14 19:13:12 UTC
I just found another game with the same issue: X3 Terran Conflict
When I enable AA it behaves the same way as swkotor with AA enabled

swkotor, AA disabled on start: https://drive.google.com/file/d/0B42CQY2wGHumalllYjVqQ1NJSEk/view?usp=sharing
swkotor, AA enabled on start: https://drive.google.com/file/d/0B42CQY2wGHumOFZDeWJlanFfTlE/view?usp=sharing

X3TC, AA disable on start: https://drive.google.com/file/d/0B42CQY2wGHumZVYyT1JhNkZUSk0/view?usp=sharing
X3TC, AA enabled on start: https://drive.google.com/file/d/0B42CQY2wGHumazNhVmpKVFBaZ3c/view?usp=sharing
Comment 3 EoD 2015-11-14 19:52:40 UTC
I should have mentioned that the apitrace replays just fine on both 32bit and 64bit apitrace executables.

The 3rd game with probably the same issue is Borderlands 2. Same screen garbage while all the replays are fine.
Comment 4 EoD 2015-11-14 20:31:03 UTC
I found the cause of the issue. It only happens if both of the following options have a value>0 in the .drirc:

<option name="pp_jimenezmlaa" value="0" />
<option name="pp_jimenezmlaa_color" value="0" />

I am not sure if this is a bug or if the error was on my side. If it is not bug, feel free to close it.
Comment 5 Christoph Brill 2015-11-18 17:08:49 UTC
Replays fine on Redwood XT (5670) with mesa 11.0.5.
Comment 6 EoD 2015-11-18 19:51:13 UTC
As I already stated, the apitrace trace did not cause the problem to trigger. I am sorry for the misleading information.
Comment 7 Alex Deucher 2015-11-18 21:56:37 UTC
The pp_jimenezmlaa options enable post processing AA options which may not be compatible with MSAA.
Comment 8 EoD 2015-11-19 20:16:11 UTC
Can't you disable the postprocessing AA when MSAA is enabled? Or at least give a huge warning/error message in such a case?

It took me a very long time to figure the problem out (neither an error, nor any other way of telling me the correlation) and I am pretty sure there are many more people out there encountering the bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.