Bug 92970 - Feature request: Implement __DRIimageExtension's blitImage
Summary: Feature request: Implement __DRIimageExtension's blitImage
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 97853 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-11-16 17:56 UTC by Axel Davy
Modified: 2019-09-25 18:55 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Davy 2015-11-16 17:56:48 UTC
blitImage is part of __DRIimageExtension Mesa internal API.

It is used to blit from a surface to another (I don't expect it would be difficult to implement for an intel dev).

The extension is required for the secondary card for DRI_PRIME on egl/wayland, glx dri3 (and soon egl/x11 dri3).

While if you are on a dedicated card it doesn't make a lot of sense to use DRI_PRIME to render on the integrated gpu (thus explaining the current low interest to implement the function), we could imagine it be used by future wayland compositors when enabling the use of several displays connected to different cards (one of the big things wayland is supposed to solve).

As Wayland compositors begin to be more and more ready, I suggest to implement that function soon, so that when wayland compositors become ready enough to begin to implement advanced functionnalities, blitImage would be ready for intel as well for Mesa stable.
Comment 1 Matt Turner 2016-11-02 07:20:31 UTC
*** Bug 97853 has been marked as a duplicate of this bug. ***
Comment 2 tempel.julian 2018-07-06 15:10:06 UTC
I want to run applications on the integrated instead of the dedicated GPU (because I don't want to use proprietary Nvidia Linux drivers) and this missing feature is blocking me from it.
Comment 3 GitLab Migration User 2019-09-25 18:55:10 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1502.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.