Bug 93093 - [SNB, regression] arb_draw_indirect.arb_draw_indirect-draw-arrays-shared-binding
Summary: [SNB, regression] arb_draw_indirect.arb_draw_indirect-draw-arrays-shared-binding
Status: CLOSED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Tapani Pälli
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-24 17:25 UTC by Mark Janes
Modified: 2015-12-07 19:30 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2015-11-24 17:25:33 UTC
the mesa patch series ending in 2571a768d6cacfbc7e434dfc2b6d01bdf5be21a6 regressed this test on SNB:

piglit.spec.arb_draw_indirect.arb_draw_indirect-draw-arrays-shared-binding.snbgt2m64 (from piglit)
Failing for the past 1 build (Since Unstable#3701 )
Took 15 ms.
Standard Output

/tmp/build_root/m64/lib/piglit/bin/arb_draw_indirect-draw-arrays-shared-binding -auto -fbo
piglit: debug: Requested an OpenGL 3.1 Forward-Compatible Core Context, and received a matching 3.3 context

Unexpected GL error: GL_INVALID_ENUM 0x500
(Error at /mnt/space/jenkins/jobs/Leeroy/workspace/repos/piglit/tests/spec/arb_draw_indirect/draw-arrays-shared-binding.c:131)

Standard Error

Mesa: User error: GL_INVALID_ENUM in glBindBufferARB(target 0x8f3f)
Mesa: User error: GL_INVALID_ENUM in glBufferData(target)
Comment 1 Timothy Arceri 2015-11-24 22:04:22 UTC
Hi Mark,

Its odd that this is fails only on SNB I would have though this validation is all done in core Mesa.

Unfortunately I don't have a SNB, tested on IVB and it works. Maybe Tapani could look at this if he has one as he wrote the piglit test (which seems to have landed just after I did my testing in the CI system) and he also knows what my patch is about.
Comment 2 Tapani Pälli 2015-11-25 04:34:53 UTC
Sure, I'll take a look. My first guess is that SNB does not support draw indirect and I'm not correctly requiring it for the test.
Comment 3 Kenneth Graunke 2015-11-25 19:25:10 UTC
Correct, ARB_draw_indirect isn't supported prior to Ivybridge.
Comment 4 Tapani Pälli 2015-11-26 05:56:58 UTC
commit b8403cf40a050daab18b24d570dbcfaeb2e7ecc4
Author: Tapani Palli <tpalli@tpalli-mobl2.ger.corp.intel.com>
Date:   Wed Nov 25 06:40:57 2015 +0200

    arb_draw_indirect: require extension in shared-binding test
    
    Signed-off-by: Tapani Pälli <tapani.palli@intel.com>
    Reviewed-by: Mark Janes <mark.a.janes@intel.com>
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=93093


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.