Bug 93214 - complete system freeze ubuntu 15.10 kernel 4.2 4.4
Summary: complete system freeze ubuntu 15.10 kernel 4.2 4.4
Status: CLOSED DUPLICATE of bug 88012
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-02 14:55 UTC by scani
Modified: 2017-07-24 22:44 UTC (History)
3 users (show)

See Also:
i915 platform: BYT
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description scani 2015-12-02 14:55:11 UTC
I run Ubuntu 15.10 64bit and I am experiencing a complete system freeze with Linux kernels 4.2 and 4.4. Now I am running the 4.1.12 kernel and there are no more freezes. The whole bug-reporting thing started here https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1509723 and the conclusion was made it is a kernel-specific problem and I think perhaps Intel Bay Treil Graphics. I filed a previous bug-report here https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1511019 I was forwarded here after filing a bug on https://bugzilla.kernel.org/show_bug.cgi?id=108721
Comment 1 Christian Wansart 2015-12-02 15:44:30 UTC
I experience the same bug on an Acer Aspire ES1-311 also intel graphics chip. I also started the original bug report in the Ubuntu bugtracker.
Comment 2 Karl Kropf 2015-12-04 21:32:39 UTC
I can confirm this bug on a gigabyte brix GB-BXBT 1900 with a Celeron J1900 @ 1.99GHz × 4 and Bay Trail/Atom Z36xxx/Z37xxx Series Graphics & Display.  The freeze has occurred (randomly) when the machine is idle, streaming video (youtube) or while using applications.
Comment 3 Karl Kropf 2015-12-05 08:47:37 UTC
Should have added to Comment 2 - running Ubuntu 15.10 with kernel 4.2.0.19.21.
Comment 4 freek_vandeursen 2015-12-05 12:15:42 UTC
This applies to me as well. Total system freezes without any noticeable errors in any log files I could find.

Hardware is an Acer ES1-711 laptop.

After rolling back to 4.1.12 kernel everything works perfect again.
Comment 5 scani 2015-12-06 08:26:34 UTC
Got 2 new freezes on 4.1.12 kernel in 2 days.
Comment 6 julio.borreguero 2015-12-07 12:50:59 UTC
i am affected by this bug with kernel versions 4.3

i am running gentoo linux, but have another partition with linux mint rebecca.
linux mint rebecca runs stable with a 4.0.4 kernel, but freezes on 4.3 kernels.

for gentoo i have tried:

3.14.48 freeze
4.3.0-rc7 freeze
4.3.0-rc6 freeze 
4.1.12 stable for several weeks now

i have treid many more kernel from the 4.x series, but have no track of the versions anymore.

here goes my system info:

# lspci -v
00:00.0 Host bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register (rev 0e)
	Subsystem: Acer Incorporated [ALI] Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register
	Flags: bus master, fast devsel, latency 0
	Kernel driver in use: iosf_mbi_pci

00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e) (prog-if 00 [VGA controller])
	Subsystem: Acer Incorporated [ALI] Atom Processor Z36xxx/Z37xxx Series Graphics & Display
	Flags: bus master, fast devsel, latency 0, IRQ 90
	Memory at 90000000 (32-bit, non-prefetchable) [size=4M]
	Memory at 80000000 (32-bit, prefetchable) [size=256M]
	I/O ports at 3050 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [d0] Power Management version 2
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [b0] Vendor Specific Information: Len=07 <?>
	Kernel driver in use: i915
	Kernel modules: i915

00:13.0 SATA controller: Intel Corporation Device 0f23 (rev 0e) (prog-if 01 [AHCI 1.0])
	Subsystem: Acer Incorporated [ALI] Device 0939
	Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 87
	I/O ports at 3048 [size=8]
	I/O ports at 305c [size=4]
	I/O ports at 3040 [size=8]
	I/O ports at 3058 [size=4]
	I/O ports at 3020 [size=32]
	Memory at 9091e000 (32-bit, non-prefetchable) [size=2K]
	Capabilities: [80] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [70] Power Management version 3
	Capabilities: [a8] SATA HBA v1.0
	Kernel driver in use: ahci

00:14.0 USB controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series USB xHCI (rev 0e) (prog-if 30 [XHCI])
	Subsystem: Acer Incorporated [ALI] Atom Processor Z36xxx/Z37xxx Series USB xHCI
	Flags: bus master, medium devsel, latency 0, IRQ 88
	Memory at 90900000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: [70] Power Management version 2
	Capabilities: [80] MSI: Enable+ Count=1/8 Maskable- 64bit+
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_pci

00:1a.0 Encryption controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine (rev 0e)
	Subsystem: Acer Incorporated [ALI] Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine
	Flags: bus master, fast devsel, latency 0, IRQ 255
	Memory at 90800000 (32-bit, non-prefetchable) [size=1M]
	Memory at 90700000 (32-bit, non-prefetchable) [size=1M]
	Capabilities: [80] Power Management version 3
	Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit-

00:1b.0 Audio device: Intel Corporation Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller (rev 0e)
	Subsystem: Acer Incorporated [ALI] Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller
	Flags: bus master, fast devsel, latency 0, IRQ 91
	Memory at 90910000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [50] Power Management version 2
	Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel

00:1c.0 PCI bridge: Intel Corporation Device 0f48 (rev 0e) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	I/O behind bridge: 00004000-00004fff
	Capabilities: [40] Express Root Port (Slot+), MSI 00
	Capabilities: [80] MSI: Enable- Count=1/1 Maskable- 64bit-
	Capabilities: [90] Subsystem: Acer Incorporated [ALI] Device 0939
	Capabilities: [a0] Power Management version 3
	Kernel driver in use: pcieport

00:1c.2 PCI bridge: Intel Corporation Device 0f4c (rev 0e) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0, IRQ 18
	Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
	I/O behind bridge: 00002000-00002fff
	Memory behind bridge: 90600000-906fffff
	Capabilities: [40] Express Root Port (Slot+), MSI 00
	Capabilities: [80] MSI: Enable- Count=1/1 Maskable- 64bit-
	Capabilities: [90] Subsystem: Acer Incorporated [ALI] Device 0939
	Capabilities: [a0] Power Management version 3
	Kernel driver in use: pcieport

00:1c.3 PCI bridge: Intel Corporation Device 0f4e (rev 0e) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0, IRQ 19
	Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
	I/O behind bridge: 00001000-00001fff
	Memory behind bridge: 90500000-905fffff
	Prefetchable memory behind bridge: 0000000090400000-00000000904fffff
	Capabilities: [40] Express Root Port (Slot+), MSI 00
	Capabilities: [80] MSI: Enable- Count=1/1 Maskable- 64bit-
	Capabilities: [90] Subsystem: Acer Incorporated [ALI] Device 0939
	Capabilities: [a0] Power Management version 3
	Kernel driver in use: pcieport

00:1f.0 ISA bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit (rev 0e)
	Subsystem: Acer Incorporated [ALI] Atom Processor Z36xxx/Z37xxx Series Power Control Unit
	Flags: bus master, medium devsel, latency 0
	Capabilities: [e0] Vendor Specific Information: Len=0c <?>

00:1f.3 SMBus: Intel Corporation Device 0f12 (rev 0e)
	Subsystem: Acer Incorporated [ALI] Device 0939
	Flags: medium devsel, IRQ 255
	Memory at 90918000 (32-bit, non-prefetchable) [size=32]
	I/O ports at 3000 [size=32]
	Capabilities: [50] Power Management version 3

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
	Subsystem: Acer Incorporated [ALI] RTL8723BE PCIe Wireless Network Adapter
	Flags: bus master, fast devsel, latency 0, IRQ 18
	I/O ports at 2000 [size=256]
	Memory at 90600000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [70] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Device Serial Number 00-23-b7-fe-ff-4c-e0-00
	Capabilities: [150] Latency Tolerance Reporting
	Capabilities: [158] L1 PM Substates
	Kernel driver in use: rtl8723be
	Kernel modules: rtl8723be

03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
	Subsystem: Acer Incorporated [ALI] RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
	Flags: bus master, fast devsel, latency 0, IRQ 89
	I/O ports at 1000 [size=256]
	Memory at 90500000 (64-bit, non-prefetchable) [size=4K]
	Memory at 90400000 (64-bit, prefetchable) [size=16K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [70] Express Endpoint, MSI 01
	Capabilities: [b0] MSI-X: Enable- Count=4 Masked-
	Capabilities: [d0] Vital Product Data
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Virtual Channel
	Capabilities: [160] Device Serial Number 00-00-00-00-00-00-00-00
	Capabilities: [170] Latency Tolerance Reporting
	Kernel driver in use: r8169
	Kernel modules: r8169
Comment 7 Karl Kropf 2015-12-09 14:02:31 UTC
Further to comments 2 and 3, the most frequent trigger for the freeze is mouse movements.
Comment 8 DES 2015-12-28 14:18:34 UTC
I experience the same bug on an Acer Aspire ES1-311 on Ubuntu 15.10.
As discussed in the Ubuntu Forum [1] only downgrading to Kernel 
Linux compe 4.1.12-040112-generic #201510262131 SMP Tue Oct 27 01:33:09 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux fixed the Problem.

My Bios is the latest Version 1.11 from 2015/07/03

[1]https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1511019

Please advice how this can be fixed in an current future Kernel.
Comment 9 Christian Wansart 2015-12-28 15:08:13 UTC
DES I got 3 more freezes so far, so I tried appending "intel_idle.max_cstate=1" to the GRUB cmdline as mentioned here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1509723/comments/42

So far it works. You could try that too.
Comment 10 DES 2016-01-01 14:22:15 UTC
Thank you for letting me know. I added "intel_idle.max_cstate=1". I hope it works.


(In reply to Christian Wansart from comment #9)
> DES I got 3 more freezes so far, so I tried appending
> "intel_idle.max_cstate=1" to the GRUB cmdline as mentioned here:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1509723/comments/42
> 
> So far it works. You could try that too.
Comment 11 julio.borreguero 2016-01-07 22:40:07 UTC
I added "intel_idle.max_cstate=1" to the cmdline in hrub running kernel 4.4.0-rc6 and got a system freeze after 3 days.
Very stable under 4.1.12 for months without any parameters.
Comment 12 Jani Nikula 2016-01-08 10:07:33 UTC
Could be a dupe of bug 88012, which is moved to https://bugzilla.kernel.org/show_bug.cgi?id=109051
Comment 13 Dave Hindle 2016-02-05 14:52:06 UTC
Thanks everyone - save me my sanity - max_cstate=1 solved it. Lets hope the kernel fix comes around soon.
Comment 14 Jani Nikula 2016-09-20 12:19:59 UTC

*** This bug has been marked as a duplicate of bug 88012 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.