Bug 93318 - ElCap: OpenGL widget in notebook page stays in front
Summary: ElCap: OpenGL widget in notebook page stays in front
Status: RESOLVED MOVED
Alias: None
Product: XQuartz
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 2.7.8 (xserver-1.16.4)
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-10 12:08 UTC by Stefan Hautsch
Modified: 2019-05-23 18:36 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Screenshots describing the problem (1.57 MB, text/plain)
2015-12-10 12:08 UTC, Stefan Hautsch
Details
attachment-9290-0.html (1.70 KB, text/html)
2019-05-23 18:36 UTC, Stefan Hautsch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Hautsch 2015-12-10 12:08:31 UTC
Created attachment 120451 [details]
Screenshots describing the problem

We are developing a freeware simulation software called Z88Aurora. The GUI is based on GTK2 and is released for Windows, Linux and OS X operating systems.

For OS X we use MacPorts to install all needed libs and then ship our software with a reduced package including the needed files only.

Everythink works fine on Linux and Windows, but on OS X we are experiencing a problem since the release of El Capitan (OS X 10.11).

The main GTK notebook page includes an OpenGL widget (gtk_gl_area) which displays the part geometry. When selecting another page, this OpenGL widget stays in front and does not disappear (cp. screenshots in attachment).

This problem only occurs on OS X El Capitan with XQuartz version 2.7.8 and 2.7.9 beta 1. XQuartz 2.7.8. works fine on OS X 10.10 and does not cause any problems with the OpenGL window.

Please let me know if this is a known error in XQuartz or where this needs to be fixed.

Kind regards,
Stefan
Comment 1 Jeremy Huddleston Sequoia 2015-12-10 19:17:08 UTC
It's an OS X regression that I will hopefully be able to workaround in libXplugin.
Comment 2 Stefan Hautsch 2015-12-11 06:46:46 UTC
Thank you for your quick response! Is it possible to announce the fix here, so I know when we can release our software for El Capitan? Or will that be mentioned in the release notes?
Comment 3 Jeremy Huddleston Sequoia 2015-12-13 17:55:13 UTC
It'll be mentioned here and in the release notes.
Comment 4 GitLab Migration User 2019-05-23 18:30:43 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/761.
Comment 5 Stefan Hautsch 2019-05-23 18:36:33 UTC
Created attachment 144334 [details]
attachment-9290-0.html


Sehr geehrte Damen und Herren,

vielen Dank für Ihre Nachricht.

Ich bin nicht mehr an der Universität Bayreuth beschäftigt. Ihre E-Mail wird nicht weitergeleitet.
Bitte wenden Sie sich direkt an das Sekretariat des Lehrstuhls per E-Mail an konstruktionslehre.cad@uni-bayreuth.de oder über Tel.: +49 (0) 921 55 7191.

Mit freundlichen Grüßen
Stefan Hautsch

----------------------------------------------------------------------------------------------------
Dear Sir or Madam,

thank you for your message.

I am not longer working at the University of Bayreuth.
Your e-mail will not be forwarded.
Please contact the chair's secretary's office via mail to konstruktionslehre.cad@uni-bayreuth.de or by phone: +49 (0) 921 55 7191.

Kind regards,
Stefan Hautsch


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.