Bug 93324 - [HSW,BDW,SKL][GLES 3.1 CTS]ES31-CTS.shader_image_load_store.advanced-sync-imageAccess2
Summary: [HSW,BDW,SKL][GLES 3.1 CTS]ES31-CTS.shader_image_load_store.advanced-sync-ima...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Marta Löfstedt
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 92778
  Show dependency treegraph
 
Reported: 2015-12-10 12:43 UTC by Marta Löfstedt
Modified: 2016-01-14 11:17 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marta Löfstedt 2015-12-10 12:43:51 UTC
Software versions:
    4.4.0-040400rc4-generic
    OpenGL version string: 3.0 Mesa 11.2.0-devel (git-83e8e07)

GPU hardware:
    OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2) 
    00:02.0 VGA compatible controller [0300]: Intel Corporation Sky Lake Integrated Graphics [8086:1912] (rev 06)

CPU hardware:
    x86_64
    Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz
-----------------
Software versions:
    4.3.0-rc3+
    OpenGL version string: 3.0 Mesa 11.2.0-devel (git-83e8e07)

GPU hardware:
    OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 5300 (Broadwell GT2) 
    00:02.0 VGA compatible controller [0300]: Intel Corporation Broadwell-U Integrated Graphics [8086:161e] (rev 06)

CPU hardware:
    x86_64
    Genuine Intel(R) CPU 0000 @ 0.60GHz
------------------
Software versions:
    4.2.0-1-generic
    OpenGL version string: 3.0 Mesa 11.2.0-devel (git-83e8e07)

GPU hardware:
    OpenGL renderer string: Mesa DRI Intel(R) Haswell Desktop 
    00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06)

CPU hardware:
    x86_64
    Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz
-----------------
CTS version:
git@67ae88f31295

command: 
./glcts --deqp-case=ES31-CTS.shader_image_load_store.advanced-sync-imageAccess2

Environment:
Mesa built with: --enable-debug
export MESA_GLES_VERSION_OVERRIDE=3.1
export MESA_EXTENSION_OVERRIDE=GL_ARB_compute_shader
Comment 1 Marta Löfstedt 2015-12-15 14:36:51 UTC
With: 
mesa: git@10b7a7c344
and:
http://patchwork.freedesktop.org/patch/68192/
http://patchwork.freedesktop.org/patch/68191/
http://patchwork.freedesktop.org/patch/68190/
http://patchwork.freedesktop.org/patch/68189/

The test pass on SKL and BDW, but still not on HSW.
Comment 2 Francisco Jerez 2015-12-17 14:33:54 UTC
(In reply to Marta Löfstedt from comment #1)
> With: 
> mesa: git@10b7a7c344
> and:
> http://patchwork.freedesktop.org/patch/68192/
> http://patchwork.freedesktop.org/patch/68191/
> http://patchwork.freedesktop.org/patch/68190/
> http://patchwork.freedesktop.org/patch/68189/
> 
> The test pass on SKL and BDW, but still not on HSW.

Are you sure?  The SSBO bug fix to enable FS dispatch fixes this for me on HSW.
Comment 3 Marta Löfstedt 2015-12-17 14:41:17 UTC
Yes I am sure, I run on my HSW development machine. However, I have had some discrepancies in the results with Tapani before...

I use the gles31_151217 branch from my github:
https://github.com/MartaLo/mesa/tree/gles31_151217

Maybe I forgot some patches...
Comment 4 Francisco Jerez 2015-12-17 15:03:37 UTC
(In reply to Marta Löfstedt from comment #3)
> Yes I am sure, I run on my HSW development machine. However, I have had some
> discrepancies in the results with Tapani before...
> 
> I use the gles31_151217 branch from my github:
> https://github.com/MartaLo/mesa/tree/gles31_151217
> 
> Maybe I forgot some patches...

Odd, it definitely passes for me with those fixes alone.  However as I just pointed out on the mailing list SSBOs are still not setting the early depth/stencil control bits and UAV-only bit correctly on HSW, you could try playing around with those although I doubt they will have any effect on this specific test-case.
Comment 5 Marta Löfstedt 2016-01-14 11:17:58 UTC
I can't reproduce this issue with Mesa git@f4ab7340c


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.