Bug 93388 - [i965, regression, bisection] MESA_FORMAT_B8G8R8X8_SRGB changes break kwin
Summary: [i965, regression, bisection] MESA_FORMAT_B8G8R8X8_SRGB changes break kwin
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-15 17:27 UTC by Mike Lothian
Modified: 2016-08-23 23:04 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Lothian 2015-12-15 17:27:49 UTC
Since the 3 patches were added:

i965: Use MESA_FORMAT_B8G8R8X8_SRGB for RGB visuals
i965: Add B8G8R8X8_SRGB to the alpha format override
i965: Add MESA_FORMAT_B8G8R8X8_SRGB to brw_format_for_mesa_format

Kwin no longer starts correctly on my Skylake system with FW5.17 & Plasma 5.5

I can still see the console and the mouse renders and I can see a popup telling me the wifi has connected. If I disable compositing I can logon, but opening the compositor settings the control panel segfaults in i965_drv.so

Going back to the previous commit before these patches solves the issue for me

Please let me know if you'd like any more details or logs
Comment 1 Mike Lothian 2015-12-16 10:05:52 UTC
Just to be clear I only need to revert 839793680f99b8387bee9489733d5071c10f3ace
Comment 2 Christoph Haag 2015-12-16 14:35:45 UTC
See also bug 92759, comment 13
Comment 3 Neil Roberts 2015-12-16 14:56:23 UTC
I've sent a revert for the patch because it looks like it's not going to be trivial to fix properly and this bug is worse than the original bug it was fixing.

http://patchwork.freedesktop.org/patch/68408/
Comment 4 Neil Roberts 2015-12-16 17:37:53 UTC
I've pushed the revert.

http://cgit.freedesktop.org/mesa/mesa/commit/?id=61cdb7665f7bd147533cdc5


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.