Bug 93408 - [BDW,SKL][GLES 3.1 CTS]ES31-CTS.shader_image_load_store.basic-allFormats-store-fs
Summary: [BDW,SKL][GLES 3.1 CTS]ES31-CTS.shader_image_load_store.basic-allFormats-stor...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 11.0
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 93322 (view as bug list)
Depends on:
Blocks: 92778
  Show dependency treegraph
 
Reported: 2015-12-16 14:28 UTC by Marta Löfstedt
Modified: 2016-01-11 09:23 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marta Löfstedt 2015-12-16 14:28:02 UTC
Software versions:
    4.4.0-040400rc4-generic
    OpenGL version string: 3.0 Mesa 11.2.0-devel (git-8e195a6)

GPU hardware:
    OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2) 
    00:02.0 VGA compatible controller [0300]: Intel Corporation Sky Lake Integrated Graphics [8086:1912] (rev 06)

CPU hardware:
    x86_64
    Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz
-----------------
Software versions:
    4.3.0-rc3+
    OpenGL version string: 3.0 Mesa 11.2.0-devel (git-8e195a6)

GPU hardware:
    OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 5300 (Broadwell GT2) 
    00:02.0 VGA compatible controller [0300]: Intel Corporation Broadwell-U Integrated Graphics [8086:161e] (rev 06)

CPU hardware:
    x86_64
    Genuine Intel(R) CPU 0000 @ 0.60GHz
------------------
CTS version Intel internal:
git@67ae88f31295

command: 
./glcts --deqp-case=ES31-CTS.shader_image_load_store.basic-allFormats-store-fs

Environment:
Ubuntu 15.10
Mesa built with: --enable-debug
export MESA_GLES_VERSION_OVERRIDE=3.1
export MESA_EXTENSION_OVERRIDE=GL_ARB_compute_shader
-------------------
Comment 1 Marta Löfstedt 2015-12-17 14:42:37 UTC
I can't reproduce the issue with Jordan/Iagos patches:

http://patchwork.freedesktop.org/patch/63033/
http://patchwork.freedesktop.org/patch/63034/
http://patchwork.freedesktop.org/patch/68471/
Comment 2 Marta Löfstedt 2016-01-08 14:45:50 UTC
*** Bug 93322 has been marked as a duplicate of this bug. ***
Comment 3 Jordan Justen 2016-01-08 21:44:51 UTC
Marta, Is this still failing for you on BDW? I tried
to reproduce it failing to verify the that patches you
mentioned fix it. Unfortunately, it was passing before
and after the patches on my BDW.

Anyway, I think all the patches you mentioned are now
committed as of:

commit 1d54ac6c9f41df240497e96770415b019ffdc6b3 
Date:   Fri Oct 23 17:08:33 2015 -0700

    mesa: Use separate indices for UBO & SSBO during binding
Comment 4 Marta Löfstedt 2016-01-11 09:23:50 UTC
Thanks for merging Jordan!
The test pass with Mesa git@a9eace326e


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.