Bug 93445 - [HSW,IVB] 11.0 stable branch regressions
Summary: [HSW,IVB] 11.0 stable branch regressions
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 11.0
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: Emil Velikov
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-18 22:47 UTC by Mark Janes
Modified: 2015-12-24 02:06 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2015-12-18 22:47:29 UTC
The series pushed to 11.0 in preparation for 11.0.8 ending in b8bac2f99b5807f24b0ed4cdaad8ad09af149ff1 had significant regressions in the conformance test suite, piglit, and dEQP.

GL Conform: 13 failures
Piglit: 112 failures
dEQP: 26 failures

The failures are hitting the following assertion:

deqp-gles2: brw_fs_generator.cpp:110: brw_reg brw_reg_from_fs_reg(fs_inst*, fs_reg*): Assertion `reg->type == reg->fixed_hw_reg.type' failed.
Comment 1 Mark Janes 2015-12-18 23:57:11 UTC
bisected to 
0ae22b3ebde780c2c88b5bfceaf172e311bd4742
Author:     Jason Ekstrand <jason.ekstrand@intel.com>
AuthorDate: Fri Dec 18 12:25:53 2015 +0000
Commit:     Emil Velikov <emil.l.velikov@gmail.com>
CommitDate: Fri Dec 18 12:26:22 2015 +0000

    i965/fs: Use a stride of 1 and byte offsets for UBOs
    
    Cc: "11.0" <mesa-stable@lists.freedesktop.org>
    Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>
    (cherry picked from commit 13ad8d03f201a4d09bf7ab9078b00807d61dfada)
    [Emil Velikov]
     - s/const_offset_reg.ud/const_offset_reg.fixed_hw_reg.dw1.ud/
     - s/brw_imm_ud/fs_reg/
    
    Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com>
    
    Conflicts:
    	src/mesa/drivers/dri/i965/brw_fs.cpp
    	src/mesa/drivers/dri/i965/brw_fs_nir.cpp
Comment 2 Jason Ekstrand 2015-12-19 00:09:21 UTC
I think the answer here is to just revert those patches.  They could be made to work, but it would take more reworking than just the trivial conflicts.
Comment 3 Kenneth Graunke 2015-12-20 02:25:21 UTC
Er, I think those were mistagged.  I had hoped they would be in 11.1.0, but never intended them to hit 11.0.x.  It's too invasive of a change for a stable branch...
Comment 4 Mark Janes 2015-12-24 02:06:04 UTC
Emil fixed up the branch.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.