Bug 93567 - [DRI3][SNA] Sandybridge (gen6, gt2) backend: blank(black) elements
Summary: [DRI3][SNA] Sandybridge (gen6, gt2) backend: blank(black) elements
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-03 13:53 UTC by Hanno Meyer-Thurow
Modified: 2017-04-09 11:04 UTC (History)
3 users (show)

See Also:
i915 platform: SNB
i915 features:


Attachments
system information (uname -a, lspci -vv -k, packages info, xorg log) (46.66 KB, text/plain)
2016-01-03 13:53 UTC, Hanno Meyer-Thurow
no flags Details
blank(black) elements (81.32 KB, image/png)
2016-01-03 13:54 UTC, Hanno Meyer-Thurow
no flags Details
gpu hang on firefox painting background/ui elements of webpage (3.34 MB, text/plain)
2016-01-03 19:27 UTC, Hanno Meyer-Thurow
no flags Details
gpu hang after login (display manager already being corrupted) (3.34 MB, text/plain)
2016-01-06 07:27 UTC, Hanno Meyer-Thurow
no flags Details
video: mouse cursor versus control key (350.33 KB, video/x-matroska)
2016-03-20 10:32 UTC, Hanno Meyer-Thurow
no flags Details
video: trash icon versus control key (497.16 KB, video/x-matroska)
2016-03-20 10:33 UTC, Hanno Meyer-Thurow
no flags Details
video: trash icon focus lost (302.70 KB, video/x-matroska)
2016-03-20 10:34 UTC, Hanno Meyer-Thurow
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hanno Meyer-Thurow 2016-01-03 13:53:27 UTC
Created attachment 120777 [details]
system information (uname -a, lspci -vv -k, packages info, xorg log)

I am using xf86-video-intel git version. latest release from last year has a bad experience with my hardware. Using dri2/sna or dri2/uxa exhibits kernel gpu hangs; dri3/sna has the best experience until now without kernel gpu hangs.

Though, sporadically ui elements are not redrawn. image will be attached.

This happens in firefox quite often, combobox pull-downs are black, load a page and the ui element in focus is black, then redrawn after a moment.

Youtube HTML5 player in firefox:
- newly drawn elements are black, move mouse over elements, then it is redrawn.
- click on an element and other elements turn blank(black).
- close fullscreen video -> mate desktop panel is not redrawn.

System information is attached.

If you need any other information, let me know.
Comment 1 Hanno Meyer-Thurow 2016-01-03 13:54:39 UTC
Created attachment 120778 [details]
blank(black) elements
Comment 2 Chris Wilson 2016-01-03 19:26:32 UTC
The gpu hang (unfortunately) is not the subject of this bug report. Just some interaction not part of the ddx.
Comment 3 Hanno Meyer-Thurow 2016-01-03 19:27:48 UTC
Created attachment 120783 [details]
gpu hang on firefox painting background/ui elements of webpage

Actually, I got a hang in firefox.
Last days I got gpu hangs very rarely on cold boot starting desktop manager lightdm. If I get to save the hang error then, I will post it here.
Comment 4 Hanno Meyer-Thurow 2016-01-06 07:27:51 UTC
Created attachment 120824 [details]
gpu hang after login (display manager already being corrupted)
Comment 5 wbrana 2016-01-26 13:59:23 UTC
I have similar problem when mplayer or mpv using OpenGL output is switching from full screen mode to windowed mode using keyboard shortcut on Xfce with compositor disabled. Window of application which is behind mplayer/mpv isn't repainted completely.
Comment 6 Hanno Meyer-Thurow 2016-02-14 17:43:06 UTC
I swapped the battery for a new one, updated kernel to 4.4.1(which fixes the invisible cursor issue), xorg to 1.18.1 and rebuilt xf86-video-intel git today.

It is not triggered that often, now. Though, Google Maps triggers blanking of Chromium 48 tab and the desktop background and icons and if I do not force a reboot in time the laptop freezes.

The freeze is a usual pattern after elements start being blanked, if I cannot reboot in time.
Comment 7 Hanno Meyer-Thurow 2016-03-20 09:37:37 UTC
Another way to reproduce, sadly sporadically, blanking is to press the control key.
Sometimes a square beneath the mouse turns black independently of application or desktop is visible.
Comment 8 Hanno Meyer-Thurow 2016-03-20 10:32:20 UTC
Created attachment 122435 [details]
video: mouse cursor versus control key
Comment 9 Hanno Meyer-Thurow 2016-03-20 10:33:21 UTC
Created attachment 122436 [details]
video: trash icon versus control key
Comment 10 Hanno Meyer-Thurow 2016-03-20 10:34:07 UTC
Created attachment 122437 [details]
video: trash icon focus lost
Comment 11 wbrana 2016-04-14 13:25:38 UTC
my problem seems to be fixed
Comment 12 Hanno Meyer-Thurow 2016-07-19 07:23:55 UTC
Another round of system updates with kernel 4.6.3 and xorg-server 1.18.3 fixed two of three video samples of blanking elements.
Comment 13 Hanno Meyer-Thurow 2016-07-19 07:37:18 UTC
Just noticed that Google Maps with Chromium 51 behaves. As do the random freezes seem to be gone, too.

Well, I enabled option TearFree - I wonder if there is any connection.
Comment 14 Hanno Meyer-Thurow 2017-04-09 08:45:49 UTC
Just noticed, that the "mouse cursor versus control key" issue is related to MATE desktop feature "show position of mouse cursor when control key is pressed".

Let's see if I can identify the code MATE executes to cause this black square.
Comment 15 Hanno Meyer-Thurow 2017-04-09 11:03:08 UTC
Hokay, MATE had their own issue drawing that mouse cursor position highlight:
https://github.com/mate-desktop/mate-control-center/issues/278

After updating, I saw that black square once for a very very short amount of time. But now, I cannot reproduce anymore. Though, even if it may occur again, it would not be worth the time inspecting.

Since the last issue of this bugreport is resolved - for me - I will close this report.

Resolution: Have a somewhat proper power supply for your laptop and use a recent kernel (>= 4.6) as well as snapshot of xf86-video-intel driver.
Comment 16 Hanno Meyer-Thurow 2017-04-09 11:04:38 UTC
Closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.