Bug 93591 - [TONGA] ARK Survival Evolved: corruption of main menu textures
Summary: [TONGA] ARK Survival Evolved: corruption of main menu textures
Status: RESOLVED DUPLICATE of bug 93594
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-05 12:45 UTC by EoD
Modified: 2016-03-20 17:17 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
apitrace trace (6.42 MB, text/plain)
2016-01-05 12:45 UTC, EoD
Details
apitrace trace (6.42 MB, application/x-xz)
2016-01-05 12:49 UTC, EoD
Details

Note You need to log in before you can comment on or make changes to this bug.
Description EoD 2016-01-05 12:45:03 UTC
Created attachment 120812 [details]
apitrace trace

I get flickering textures on buttons in the menus of ARK Survival Evolved on my Tonga.

A video of the corruption: https://www.youtube.com/watch?v=29OP-wlashA

$ glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD TONGA (DRM 3.1.0, LLVM 3.8.0)
OpenGL core profile version string: 4.1 (Core Profile) Mesa 11.2.0-devel (git-14f21f5)
OpenGL core profile shading language version string: 4.10
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

I am using the current kernel "4.4.0-rc3-geafbbd9" from cgit.freedesktop.org/~agd5f/linux/log/?h=drm-next-4.5 with powerplay enabled.


This issue does not appear on llvmpipe (neither in the apitrace replay, nor with the game).
Comment 1 EoD 2016-01-05 12:49:40 UTC
Created attachment 120813 [details]
apitrace trace

wrong mime type of attachment
Comment 2 EoD 2016-02-11 17:20:35 UTC
This issue does also not affect my Barts on r600.
Comment 3 Nicolai Hähnle 2016-02-18 15:07:21 UTC
Based on an analysis of the trace I've done some time ago this is a pixel discard problem, most likely the same as bug #93594.

*** This bug has been marked as a duplicate of bug 93594 ***
Comment 4 EoD 2016-02-19 09:14:13 UTC
(In reply to Nicolai Hähnle from comment #3)
> Based on an analysis of the trace I've done some time ago this is a pixel
> discard problem, most likely the same as bug #93594.
> 
> *** This bug has been marked as a duplicate of bug 93594 ***

I am not surprised, thanks for looking into it :)
Comment 5 Nicolai Hähnle 2016-03-14 12:49:06 UTC
So, I've looked into this again out of curiosity, because I do have an LLVM patch that can be used to work around this. However, the patch introduces some inefficiencies, and this is a game bug: it is clear from playing with the provided apitrace that a derivative is taken after a non-uniform discard/kill, which is undefined behaviour in GLSL.

Does anybody paying attention to this bug report know of a way to contact the game developer about this?
Comment 6 EoD 2016-03-20 17:17:22 UTC
(In reply to Nicolai Hähnle from comment #5)
> So, I've looked into this again out of curiosity, because I do have an LLVM
> patch that can be used to work around this. However, the patch introduces
> some inefficiencies, and this is a game bug: it is clear from playing with
> the provided apitrace that a derivative is taken after a non-uniform
> discard/kill, which is undefined behaviour in GLSL.
> 
> Does anybody paying attention to this bug report know of a way to contact
> the game developer about this?

Unfortunately there seems to be no bugtracker. The list of (core) devs can be found on their homepage http://www.instinctgames.com/#c-about-us together with email info@instinctgames.com and phone +20222913556 though.

They are apparently also use 
Twitter: https://twitter.com/instinctgames
Facebook: https://www.facebook.com/InstinctGames
Linkedin: https://www.linkedin.com/company/instinct-games

I could find the linkedin profile of one of the graphics engine programmers too: https://www.linkedin.com/in/mohammad-yusuf-2b7531a7


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.