Bug 93674 - Random font corruption
Summary: Random font corruption
Status: NEW
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Chris Wilson
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-12 02:16 UTC by Konstantin Svist
Modified: 2016-11-08 06:57 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.0.log (31.99 KB, text/plain)
2016-01-12 02:16 UTC, Konstantin Svist
no flags Details
corruption sample (8.44 KB, image/png)
2016-01-12 02:17 UTC, Konstantin Svist
no flags Details
dmesg after corruption noticed (83.17 KB, text/plain)
2016-01-13 22:32 UTC, Konstantin Svist
no flags Details
font garbled in firefox (171.62 KB, image/png)
2016-02-09 20:00 UTC, Guillaume Castagnino
no flags Details
relevant xorg log (27.96 KB, text/plain)
2016-02-09 20:29 UTC, Guillaume Castagnino
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Svist 2016-01-12 02:16:32 UTC
Created attachment 120973 [details]
xorg.0.log

Seeing an intermittent font rendering problem. Certain letters become garbled and stay that way.
Seen this inside different apps, and as part of xfce desktop.
Not all apps show the badly rendered letter at the same time. E.g. Firefox content is fine right now, but XFCE desktop & Thunderbird seem to have a problem. Yesterday, XFCE Terminal and Firefox had the problem..
Resizing the font fixes the issue, but when going back to the original size, it comes back.
Font chooser with same font & size doesn't seem to have this problem.


Not exactly sure if this is the driver's fault, but it's the one component that I compile from git, so I guess it's most likely..?

Using git version; commit 371219c34a54707a0d568c51defae478079fbf71
Comment 1 Konstantin Svist 2016-01-12 02:17:00 UTC
Created attachment 120974 [details]
corruption sample
Comment 2 Chris Wilson 2016-01-12 06:19:16 UTC
Across resume? There's a kernel bug for font corruption (where the font cache is corrupted by the BIOS).
Comment 3 Konstantin Svist 2016-01-12 07:06:22 UTC
No, just some hours after staying on after boot...
Comment 4 Chris Wilson 2016-01-12 16:08:53 UTC
Just on the off-chance something interesting happened, could you attach dmesg as well?
Comment 5 Konstantin Svist 2016-01-13 22:32:40 UTC
Created attachment 121008 [details]
dmesg after corruption noticed

Just noticed the corruption again, ~1hr 9min since clean boot
4.3.3-300.fc23.x86_64

Interesting that there's some bbswitch activity.. this corresponds to a script I run ~every hour. The interesting things it does are:
$ glxinfo
$ optirun glxinfo
$ primusrun glxinfo

..and grep for expected output.
Comment 6 Konstantin Svist 2016-01-14 19:18:43 UTC
A timing pattern is starting to emerge, looks like the corruption is tied to bumblebee/etc.

Still not clear if it's a bug in xorg/intel/bumblebee/nvidia/kernel/etc.
Should I file bugs anywhere else?
Comment 7 Konstantin Svist 2016-01-23 23:50:56 UTC
http://imgur.com/dUnjgTY can't even read the page :(
Comment 8 Guillaume Castagnino 2016-02-09 19:59:31 UTC
I think I have the same. xorg-1.18.0 and intel 2.99.917_p20160203, kernel 4.4.1 under Gentoo. I will upload a screenshot soon.
I use an intel HD4600 chipset (core i5-4690 and i7-4790)

When one caracter is garbled, it’s “forever”, until I restart X server. No suspend used. It appears after some time after a clean cold boot. I usually see the corruption in firefox or gnome-terminal. I use xfce4 desktop (current git version with opengl compositing).

Nothing in logs after corruption starts, neither in Xorg log nor in system logs or kernel logs. Tell if I can look somewhere else for some info.

I think it may be related to the driver, since this started after upgrading the driver snapshot. I had no problem with the 2.99.917 version.
Comment 9 Guillaume Castagnino 2016-02-09 20:00:10 UTC
Created attachment 121628 [details]
font garbled in firefox
Comment 10 Guillaume Castagnino 2016-02-09 20:29:27 UTC
Created attachment 121629 [details]
relevant xorg log

The /var/log/Xorg.0.log, but seems there is nothing interesting here besides the configuration
Comment 11 Konstantin Svist 2016-04-01 20:43:51 UTC
Haven't seen it in a while, guess it got fixed somewhere along the way
Comment 12 Tom Colley 2016-11-08 06:57:31 UTC
Having found font corruption in LibreOffice Writer after waking from suspend in Ubuntu 14.04, I found that this workaround worked (see http://askubuntu.com/questions/584922/how-do-i-fix-fonts-not-rendering-and-missing-letters). Essentially, you open Unity Tweak (install first if necessary). Then go to Appearance > Fonts > Antialiasing and set to "Greyscale". HTH with further diagnosis.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.