Bug 93718 - nouveau + moveablecore => endless havoc (possibly a general drm problem)
Summary: nouveau + moveablecore => endless havoc (possibly a general drm problem)
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: General (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-14 20:54 UTC by Robert White
Modified: 2019-10-14 13:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert White 2016-01-14 20:54:28 UTC
NOTE: I'm actually using the gentoo x11 overlay which seems to be an xorg git...

So reserving movable core on the linux command line seems to cause random failure in my nouveau dual monitor desktop system. (I suspect it's happening to a lessor extent on my radeon laptop as well).

So anyway, I've been using "moveablecore=2G" on my kernel command line for some time in order to accommodate hugepages (etc) for transient virtual machines. When I started playing with SDDM and kde Plasma I started getting display hangs.

The exact moment and error of the hang/error is hard to catch, but just starting sddm is enough to cause my dmesg to fill with faults. They all looked memory/state related so I started playing around.

With no kernelcore= or moveablecore= options on the kernel command line the system seems rock steady.

Using either (they both reserve a movable memory NUMA region that anonymous mappings via mmap() "like" and the kernel is free to relocate by juggling page tables and copying physical images) seems to steal data will-he/nil-he out from under nouveau.

ASIDE: I say it may be happening on my radeon laptop because Chromium gets render-hung there for odd reasons but the diagnostics are more vague.

So the work-around is to not use these options, but I suspect there's some missing page locking or whatever creating phantom failures... particularly in nouveau... particularly under high render pressure.

With "moveablecore=2G kernelcore=3G" I can't even get all the way through the sddm password entry without a messy crash.

This seems to line up with a lot of can-not-duplicate type of error reports I found with google, so I figure'd I drop my datapoint here.
Comment 1 Martin Peres 2019-10-14 13:20:26 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.