Bug 93725 - [HSW, regression, bisected] ES31-CTS.texture_gather.*depth*
Summary: [HSW, regression, bisected] ES31-CTS.texture_gather.*depth*
Status: RESOLVED DUPLICATE of bug 92589
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 11.0
Hardware: Other All
: medium normal
Assignee: Francisco Jerez
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 92778
  Show dependency treegraph
 
Reported: 2016-01-15 10:50 UTC by Marta Löfstedt
Modified: 2016-01-16 23:59 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marta Löfstedt 2016-01-15 10:50:55 UTC
Software versions:
    4.4.0-040400rc7-generic
    OpenGL version string: 3.0 Mesa 11.2.0-devel (git-18c7655)

GPU hardware:
    OpenGL renderer string: Mesa DRI Intel(R) Haswell Desktop 
    00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06)

CPU hardware:
    x86_64
    Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz
-----------------
CTS version:
Intel internal git@67ae88f31295

command: 
./glcts --deqp-case=ES31-CTS.texture_gather.*depth*

Environment:
Mesa built with: --enable-debug
export MESA_GLES_VERSION_OVERRIDE=3.1
export MESA_EXTENSION_OVERRIDE=GL_ARB_compute_shader

-------------------

All GLES 3.1 CTS texture gather test passed before commit:

commit 18c76551ee425b981efefc61f663a7781df17882
Author: Francisco Jerez <currojerez@riseup.net>
Date:   Sat Jan 2 19:02:09 2016 -0800

    i965/gen6-7: Implement stall and flushes required prior to switching pipelines.


Now 5 fail.
Comment 1 Marta Löfstedt 2016-01-15 10:55:07 UTC
These test also fail on BDW and SKL. However, due to bug 92589, the texture gather gles 3.1 CTS test cases can not be executed in the proper manner on those platforms.
Comment 2 Eero Tamminen 2016-01-15 13:00:46 UTC
Could be a co-incidence, but there was also another thing appearing between yesterday morning and today, which looks like a potential regression.  GfxBench v4 "gl_4" (GL 4.3 Car Chase) test rendering got worse; on some of the frames, most of the things are black now (just the dust from cars is visible).  I'll recheck it after this is fixed.
Comment 3 Francisco Jerez 2016-01-16 23:59:41 UTC
Heh, apparently these tests were passing on HSW by luck, we weren't uploading any sampler state for the compute pipeline so it would simply take whatever was left in the sampler state cache by the previous rendering.  The change you bisected the change to invalidates the sampler state cache on Gen7, what explains the regression.

*** This bug has been marked as a duplicate of bug 92589 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.