Bug 93809 - playing Just Cause causes system crash
Summary: playing Just Cause causes system crash
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2016-01-21 14:37 UTC by almos
Modified: 2019-11-19 09:11 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description almos 2016-01-21 14:37:03 UTC
It happens randomly, usually when lots of things are happening, like during settlement takeovers. The screen freezes, sound stops, and only the magic sysrq keys are working.

GPU is Radeon R9 270x, Linux 4.3.3, libdrm 2.4.66, Mesa 11.1.1, wine 1.7.55. I also tried gallium nine, and that made it more unstable, it crashes even when just riding around. BTW nine doesn't help with the horrible performance (5-15 fps), but it introduces several graphical glitches.
Comment 1 almos 2016-12-29 13:42:09 UTC
I tried this again with current sw stack (kernel 4.8.13, libdrm 2.74, mesa 13.1-dev, wine 2.0rc2), and the game ran for 1 hour without crashing the machine, so I guess this is fixed. The performance feels much worse now (around 2-5fps), but with nine the game is playable (but it doesn't draw shadows, and crashes very often).
Comment 2 Martin Peres 2019-11-19 09:11:24 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/amd/issues/680.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.