Bug 93992 - Xorg stuck in Uninterruptible IO state after a crash
Summary: Xorg stuck in Uninterruptible IO state after a crash
Status: RESOLVED DUPLICATE of bug 93580
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.7 (2012.06)
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Chris Wilson
QA Contact: Intel GFX Bugs mailing list
Depends on:
Reported: 2016-02-03 20:02 UTC by Franck Delache
Modified: 2016-02-03 20:39 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Franck Delache 2016-02-03 20:02:12 UTC
On a fresh boot, the first time I start the XServer it crashes with the following fatal server error:
[    13.722] (EE) xf86OpenConsole: VT_ACTIVATE failed: Input/output error
[    13.723] (EE) 
[    13.723] (EE) 

It did not cause me much trouble, since systemd will restart the XServer automatically, and it is transparent for me (the crash happens very early during boot-up).

Now I had one situation, where the XServer didn't terminate after the same crash. I see the same fatal server error in the Xorg.0.log file, but the Xorg process is stuck in Ds state (uninterruptible IO wait), and will never die.
Since the process is not dead, systemd will never try to restart the XServer. Which is more problematic.

I tried to attach gdb on the Xorg process with no luck (as if gdb wait for the process to get out of the Ds state). strace does the same thing.

The only information I can get is the main thread stack through /proc/pid/stack:
root@kxslot12:~# cat /proc/1858/stack 
[<c138b085>] __drm_modeset_lock_all+0xf5/0x100
[<c138b09a>] drm_modeset_lock_all+0xa/0x30
[<c136fa4b>] drm_fb_helper_restore_fbdev_mode_unlocked+0x1b/0x70
[<c13f2f68>] intel_fbdev_restore_mode+0x18/0x40
[<c1415095>] i915_driver_lastclose+0x35/0x40
[<c1373365>] drm_lastclose+0x25/0x110
[<c13736e7>] drm_release+0x297/0x460
[<c1125ef3>] __fput+0xc3/0x1b0
[<c1126018>] ____fput+0x8/0x10
[<c10595a9>] task_work_run+0x79/0x90
[<c1045d3d>] do_exit+0x26d/0x990
[<c104654f>] do_group_exit+0x2f/0x90
[<c104f5d2>] get_signal+0x182/0x590
[<c1001a09>] do_signal+0x19/0x980
[<c10023c5>] do_notify_resume+0x55/0x70
[<c17574b7>] work_notifysig+0x24/0x29
[<ffffffff>] 0xffffffff

Note that this problem happens on an Intel Corporation 3rd Gen Core processor Graphics Controller. I tried to reproduce this with different graphic controller (915GM and 945GM) but couldn't.
Comment 1 Chris Wilson 2016-02-03 20:39:07 UTC

*** This bug has been marked as a duplicate of bug 93580 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.