Bug 93998 - Linux 4.5-rc2 ATI Radeon 3000 Graphics not rendering correctly
Summary: Linux 4.5-rc2 ATI Radeon 3000 Graphics not rendering correctly
Status: RESOLVED NOTOURBUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-04 09:57 UTC by SMF
Modified: 2016-02-11 17:24 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (28.82 KB, text/plain)
2016-02-04 09:58 UTC, SMF
no flags Details
xorg.conf (1.50 KB, text/plain)
2016-02-04 09:59 UTC, SMF
no flags Details
dmesg output (47.83 KB, text/plain)
2016-02-04 17:33 UTC, SMF
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description SMF 2016-02-04 09:57:06 UTC
On testing linux 4.5-rc( 1 and 2) I have found that my display is not rendered correctly on starting the X server. My screen is mainly black with portions of the desktop appearing from time to time. I have tried the kernel on two different machine with different Radeon cards and the result is the same. The system is a recent LFS build and I use fvwm as my window manager. I will forward xorg.conf and Xorg.0.log files from my testing.
Comment 1 SMF 2016-02-04 09:58:51 UTC
Created attachment 121510 [details]
Xorg.0.log

XServer log file.
Comment 2 SMF 2016-02-04 09:59:41 UTC
Created attachment 121511 [details]
xorg.conf

My xorg.conf file from /etc/X11
Comment 3 Alex Deucher 2016-02-04 14:23:25 UTC
If this is a regression, can you bisect?  Please also attach your dmesg output.
Comment 4 SMF 2016-02-04 17:33:07 UTC
Created attachment 121526 [details]
dmesg output

dmesg output as requested, I will bisect as suggested. Thanks
Comment 5 Alex Deucher 2016-02-04 17:35:49 UTC
Looks like you forced dpm on.  Had you been using that previously?
Comment 6 SMF 2016-02-04 19:53:35 UTC
(In reply to Alex Deucher from comment #5)
> Looks like you forced dpm on.  Had you been using that previously?

Yes I have been using this setting for some time, I cannot remember how long (some years ?) or why I set it in the first place.
Comment 7 SMF 2016-02-04 20:35:48 UTC
(In reply to SMF from comment #6)
> (In reply to Alex Deucher from comment #5)
> > Looks like you forced dpm on.  Had you been using that previously?
> 
> Yes I have been using this setting for some time, I cannot remember how long
> (some years ?) or why I set it in the first place.

The other machine I have tested uses a Turks PRO [Radeon HD 6570/7570/8550] with the same boot settings and fails in the same way.
Comment 8 SMF 2016-02-04 21:45:15 UTC
(In reply to SMF from comment #7)
> (In reply to SMF from comment #6)
> > (In reply to Alex Deucher from comment #5)
> > > Looks like you forced dpm on.  Had you been using that previously?
> > 
> > Yes I have been using this setting for some time, I cannot remember how long
> > (some years ?) or why I set it in the first place.
> 
> The other machine I have tested uses a Turks PRO [Radeon HD 6570/7570/8550]
> with the same boot settings and fails in the same way.

Looking back over my bug history I found this activity:

https://bugzilla.kernel.org/show_bug.cgi?id=60857
Comment 9 SMF 2016-02-04 23:59:54 UTC
Result of bisect:

01c8f1c44b83a0825b573e7c723b033cece37b86 is the first bad commit
commit 01c8f1c44b83a0825b573e7c723b033cece37b86
Author: Dan Williams <dan.j.williams@intel.com>
Date:   Fri Jan 15 16:56:40 2016 -0800

    mm, dax, gpu: convert vm_insert_mixed to pfn_t
    
    Convert the raw unsigned long 'pfn' argument to pfn_t for the purpose of
    evaluating the PFN_MAP and PFN_DEV flags.  When both are set it triggers
    _PAGE_DEVMAP to be set in the resulting pte.
    
    There are no functional changes to the gpu drivers as a result of this
    conversion.
    
    Signed-off-by: Dan Williams <dan.j.williams@intel.com>
    Cc: Dave Hansen <dave@sr71.net>
    Cc: David Airlie <airlied@linux.ie>
    Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
    Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>

:040000 040000 dc71b6dc188dea4b6ce95f5fd1e4e73cc3663cbe 8a745459a14cd2a6f4e1c71fda3e54333d023f43 M	arch
:040000 040000 9e8103b65698f677e17becdac53914ca029a6197 f656e15bffef4ea8c848176a79eb50a071ec323e M	drivers
:040000 040000 3ffc222d7e0f1067772798d08777aeb54136026e e2b423f85aaaf0cb25d48d1e15771fc5bddf7981 M	fs
:040000 040000 392d2dea8185ba8f0d1c101782831ceed9aa9812 9e3001b04052daa1b3204b6f2a6e26138a4ed7dd M	include
:040000 040000 f81d8cfe3052b7259b75a58656a65efdaad40284 969d0ff262020f27a695172ce89ae5f6088e8d44 M	mm
Comment 10 Michel Dänzer 2016-02-05 02:10:15 UTC
(In reply to SMF from comment #9)
> 01c8f1c44b83a0825b573e7c723b033cece37b86 is the first bad commit
> commit 01c8f1c44b83a0825b573e7c723b033cece37b86
> Author: Dan Williams <dan.j.williams@intel.com>
[...]
>     There are no functional changes to the gpu drivers as a result of this
>     conversion.

Famous last words. :) Please report this to Dan Williams.
Comment 12 Michel Dänzer 2016-02-05 02:29:10 UTC
Thanks Alex. Resolving as not a driver bug.
Comment 13 SMF 2016-02-05 08:29:10 UTC
Tested the patch given here with linux-4.5-rc2 and it did NOT fix the problem for me:

http://lists.freedesktop.org/archives/dri-devel/2016-January/099511.html
Comment 14 Michel Dänzer 2016-02-05 08:36:11 UTC
That's unfortunate, but doesn't change that it's probably not a driver bug and that you should get in touch with Dan Williams about it.
Comment 15 SMF 2016-02-05 10:15:10 UTC
(In reply to Michel Dänzer from comment #14)
> That's unfortunate, but doesn't change that it's probably not a driver bug
> and that you should get in touch with Dan Williams about it.

Thanks just e-mailed him.
Comment 16 SMF 2016-02-11 17:24:04 UTC
(In reply to SMF from comment #15)
> (In reply to Michel Dänzer from comment #14)
> > That's unfortunate, but doesn't change that it's probably not a driver bug
> > and that you should get in touch with Dan Williams about it.
> 
> Thanks just e-mailed him.

Solution found see:

https://bugzilla.kernel.org/show_bug.cgi?id=112211

For details.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.