Bug 94033 - [HSW] GPU HANG: ecode 7:0:0x85dffffc, in kwin_x11 [367], reason: Ring hung, action: reset
Summary: [HSW] GPU HANG: ecode 7:0:0x85dffffc, in kwin_x11 [367], reason: Ring hung, a...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 13.0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-07 08:00 UTC by Alex
Modified: 2019-09-25 18:56 UTC (History)
1 user (show)

See Also:
i915 platform: HSW
i915 features: GPU hang


Attachments
dmesg (754.47 KB, text/plain)
2016-02-07 08:00 UTC, Alex
Details
/sys/class/drm/card0/error (3.08 MB, text/plain)
2016-02-07 08:02 UTC, Alex
Details
Xorg.log (19.93 KB, text/plain)
2016-02-07 16:07 UTC, Alex
Details
/sys/class/drm/card0/error (240.49 KB, application/x-bzip2)
2016-11-05 10:52 UTC, Alex
Details
dmesg (212.33 KB, application/x-bzip2)
2016-11-05 12:27 UTC, Alex
Details
Xorg.log (24.80 KB, text/plain)
2016-11-05 13:02 UTC, Alex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2016-02-07 08:00:28 UTC
Created attachment 121566 [details]
dmesg

Graphics  freeze up multiple times per day:


[   11.701071] [drm] stuck on render ring
[   11.702236] [drm] GPU HANG: ecode 7:0:0x85dffffc, in kwin_x11 [367], reason: Ring hung, action: reset
[   11.702239] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[   11.702241] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[   11.702243] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[   11.702245] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[   11.702247] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[   11.702277] [drm:i915_reset_and_wakeup] resetting chip
[   11.702363] ------------[ cut here ]------------
[   11.702374] WARNING: CPU: 1 PID: 122 at drivers/gpu/drm/i915/intel_display.c:11289 intel_mmio_flip_work_func+0x35f/0x3a0()
[   11.702377] WARN_ON(__i915_wait_request(mmio_flip->req, mmio_flip->crtc->reset_counter, false, NULL, &mmio_flip->i915->rps.mmioflips))
[   11.702381] Modules linked in:
[   11.702384]  nct6775 hwmon_vid snd_virtuoso intel_powerclamp snd_oxygen_lib efivars coretemp snd_mpu401_uart snd_pcm snd_timer sr_mod snd_rawmidi cdrom lpc_ich mfd_core efivarfs ipv6
[   11.702405] CPU: 1 PID: 122 Comm: kworker/1:3 Not tainted 4.4.0 #2
[   11.702408] Hardware name: To Be Filled By O.E.M. To Be Filled By O.E.M./B85M, BIOS P2.60 12/17/2015
[   11.702414] Workqueue: events intel_mmio_flip_work_func
[   11.702417]  ffffffff81611fc8 ffffffff811f72ee ffff8800cac73d90 ffffffff81040513
[   11.702423]  ffff8800c99a6dc0 ffff8800cac73de0 ffff88011e313180 ffff88011e317800
[   11.702427]  0000000000000000 ffffffff81040587 ffffffff815e1e64 0000000000000020
[   11.702432] Call Trace:
[   11.702440]  [<ffffffff811f72ee>] ? dump_stack+0x47/0x69
[   11.702448]  [<ffffffff81040513>] ? warn_slowpath_common+0x73/0xa0
[   11.702453]  [<ffffffff81040587>] ? warn_slowpath_fmt+0x47/0x50
[   11.702459]  [<ffffffff8106aa7c>] ? pick_next_task_fair+0x3dc/0x430
[   11.702465]  [<ffffffff81327eaf>] ? intel_mmio_flip_work_func+0x35f/0x3a0
[   11.702472]  [<ffffffff8105292e>] ? process_one_work+0x11e/0x3b0
[   11.702476]  [<ffffffff81052c02>] ? worker_thread+0x42/0x490
[   11.702480]  [<ffffffff81052bc0>] ? process_one_work+0x3b0/0x3b0
[   11.702484]  [<ffffffff81052bc0>] ? process_one_work+0x3b0/0x3b0
[   11.702490]  [<ffffffff81057908>] ? kthread+0xb8/0xd0
[   11.702497]  [<ffffffff81057850>] ? kthread_worker_fn+0x100/0x100
[   11.702503]  [<ffffffff814d709f>] ? ret_from_fork+0x3f/0x70
[   11.702508]  [<ffffffff81057850>] ? kthread_worker_fn+0x100/0x100
[   11.702512] ---[ end trace 0a1eb232d401ac46 ]---
[   11.704392] drm/i915: Resetting chip after gpu hang


Using SNA acceleration.

System environment:
-- chipset: B85
-- display connector: HDMI
-- system architecture: 64-bit
-- xf86-video-intel: 2.99.917
-- xserver: 1.18
-- mesa: 11.1.1
-- libdrm: 2.4.66
-- kernel: 4.4.0
-- Linux distribution: Gentoo
Comment 1 Alex 2016-02-07 08:02:07 UTC
Created attachment 121567 [details]
/sys/class/drm/card0/error
Comment 2 Alex 2016-02-07 16:07:35 UTC
Created attachment 121573 [details]
Xorg.log
Comment 3 yann 2016-09-13 07:25:54 UTC
Assigning to Mesa product (please let me know if I am mistaken with this GPU Hang).

From this error dump, hung is happening in render ring batch with active head at 0x7d40d2f8, with 0x7a000003 (PIPE_CONTROL) as IPEHR.

Batch extract (around 0x7d40d2f8):

0x7d40d2c8:      0x7b000005: 3DPRIMITIVE:
0x7d40d2cc:      0x00000104:    tri list random
0x7d40d2d0:      0x00000006:    vertex count
0x7d40d2d4:      0x00000000:    start vertex
0x7d40d2d8:      0x00000001:    instance count
0x7d40d2dc:      0x00000000:    start instance
0x7d40d2e0:      0x00000000:    index bias
0x7d40d2e4:      0x7a000003: PIPE_CONTROL
0x7d40d2e8:      0x00101c11:    no write, cs stall, render target cache flush, instruction cache invalidate, texture cache invalidate, vf fetch invalidate, depth cache flush,
0x7d40d2ec:      0x00000000:    destination address
0x7d40d2f0:      0x00000000:    immediate dword low
0x7d40d2f4:      0x00000000:    immediate dword high
0x7d40d2f8:      0x7a000003: PIPE_CONTROL
0x7d40d2fc:      0x00101c11:    no write, cs stall, render target cache flush, instruction cache invalidate, texture cache invalidate, vf fetch invalidate, depth cache flush,
0x7d40d300:      0x00000000:    destination address
0x7d40d304:      0x00000000:    immediate dword low
0x7d40d308:      0x00000000:    immediate dword high
0x7d40d30c:      0x780e0000: 3DSTATE_CC_STATE_POINTERS
0x7d40d310:      0x00006c81:    pointer to COLOR_CALC_STATE at 0x00006c80 (changed)
Comment 4 yann 2016-11-04 15:30:32 UTC
Please test a new version of Mesa (12 or 13) and mark as REOPENED
if you can reproduce and RESOLVED/* if you cannot reproduce.
Comment 5 Alex 2016-11-05 10:51:21 UTC
Unfortunately, problem still exists with Mesa 13.0.0 and kernel 4.8.4
Comment 6 Alex 2016-11-05 10:52:28 UTC
Created attachment 127787 [details]
/sys/class/drm/card0/error
Comment 7 Alex 2016-11-05 12:27:41 UTC
Created attachment 127788 [details]
dmesg
Comment 8 Alex 2016-11-05 13:02:59 UTC
Created attachment 127789 [details]
Xorg.log
Comment 9 Elizabeth 2018-03-21 23:07:40 UTC
Hello Alex, this should be fixed already by 17.3.6, could you confirm it? Thank you.
Comment 10 GitLab Migration User 2019-09-25 18:56:16 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1512.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.