Bug 94078 - swrast-on-vgem not supported in dri3
Summary: swrast-on-vgem not supported in dri3
Status: NEW
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/llvmpipe (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-10 15:57 UTC by Javier Jardón
Modified: 2018-04-13 10:00 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Javier Jardón 2016-02-10 15:57:26 UTC
This makes gnome-shell to crash, because Xwayland depends in dri3 now:

14:55 <daniels> strictly:~% LIBGL_ALWAYS_SOFTWARE=1 gnome-shell --wayland   
14:55 <daniels> Disabling glamor and dri3, EGL setup failed
14:55 <daniels> Failed to initialize glamor, falling back to sw
14:55 <daniels> strictly:~% gnome-shell --wayland                     
14:55 <daniels> glamor: EGL version 1.4 (DRI2):
Comment 1 Michel Dänzer 2016-02-12 03:41:57 UTC
Note that Xwayland (and by extension gnome-shell) should work perfectly fine without glamor/DRI3, so fixing the crash should be significantly easier than making glamor/DRI3 work with swrast.
Comment 2 Dave Airlie 2016-02-12 03:58:46 UTC
yes I don't think this bug has been diagnosed except via handwaving yet.

Though it does appear mutter is crashing inside glClear after my 5m of investigating.

However further investigating is blocked on some llvm build problems in rawhide that I'm trying to clear first.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.