Bug 94219 - Geom shader crash with lot of inputs
Summary: Geom shader crash with lot of inputs
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Marc-Andre Lureau
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-19 16:54 UTC by Marc-Andre Lureau
Modified: 2019-09-25 18:56 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
shader runner test (45.78 KB, text/plain)
2016-02-19 16:55 UTC, Marc-Andre Lureau
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc-Andre Lureau 2016-02-19 16:54:37 UTC
The following attached shader runner test crashes with current mesa intel driver. It passes with software, so I opened a bug for discussion.
Comment 1 Marc-Andre Lureau 2016-02-19 16:55:16 UTC
Created attachment 121846 [details]
shader runner test
Comment 2 Marc-Andre Lureau 2016-02-19 16:56:38 UTC
fwiw, this is generated by virgl. You can reproduce virgl running with the following setup:

$ vtest/virgl_test_server --no-fork

$ LIBGL_ALWAYS_SOFTWARE=y GALLIUM_DRIVER=virpipe bin/shader_runner ./tests/spec/glsl-1.50/execution/geometry/max-input-components.shader_test
Comment 3 Sergii Romantsov 2018-04-24 13:46:01 UTC
Can't reproduce crash on KBL.

-----
System:    Host: sergiiromantsov-HP-ZBook-14u-G4 Kernel: 4.13.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Unity 7.4.5 (Gtk 3.18.9-1ubuntu3.3) Distro: Ubuntu 16.04 xenial
CPU:       Dual core Intel Core i7-7500U (-HT-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 11616
           clock speeds: max: 3500 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz 4: 800 MHz
Graphics:  Card-1: Intel Device 5916 bus-ID: 00:02.0
           Card-2: Advanced Micro Devices [AMD/ATI] Opal XT [Radeon R7 M265] bus-ID: 03:00.0
           Display Server: X.Org 1.19.5 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2)
           GLX Version: 3.0 Mesa 18.2.0-devel (git-c2e159d050) Direct Rendering: Yes
-----

Used attached test-file for /bin/shader_runner (with and without LIBGL_ALWAYS_SOFTWARE=y).
Test fails but crash wasn't observed.
Comment 4 Sergii Romantsov 2018-04-24 13:49:14 UTC
Hello, Mark-Andre.

Could you, please, specify what generation have you used and what mesa version it was?
Comment 5 Denis 2018-05-11 15:56:48 UTC
Hi, I also tryed to reproduce this with help of piglit shader_runner. Didn't reproduce on these configurations:


SNB (mesa versions 18.0.1, 17.2.6, 13.0.0) (openSUSE, Wayland, plasmashell)
KBL (mesa versions 13.0.6, 17.2.8, 18.1.0) (ubuntu, X, Unity)
SKL (mesa versions 13.0.0, 17.3.6, 18.1.0) (ubuntu, X, Plasmashell)
Comment 6 GitLab Migration User 2019-09-25 18:56:23 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1515.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.