Bug 94229 - GPU hang when application is using hardware acceleration
Summary: GPU hang when application is using hardware acceleration
Status: CLOSED DUPLICATE of bug 89360
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: high major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-20 13:01 UTC by Vladimir Miloserdov
Modified: 2017-07-24 22:42 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features: GPU hang


Attachments
Full dmesg output (101.86 KB, text/plain)
2016-02-20 13:01 UTC, Vladimir Miloserdov
no flags Details
Error log from /sys/class/drm/card0/error (28.65 KB, application/x-bzip2)
2016-02-20 13:05 UTC, Vladimir Miloserdov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Miloserdov 2016-02-20 13:01:32 UTC
Created attachment 121859 [details]
Full dmesg output

I've been encountering this bug since I've bought this laptop in Nov, 2015. When I launch an application that uses hw acceleration (e.g. any video game, firefox (with hw accel enabled), video in vlc/mplayer, etc). This *bug* may include screen blinking and/or graphical anomalies and/or system hang for a while (or forever). I also noticed the *bug* behavior is changing a little over mesa/libdrm/kernel module/kernel upgrades I usually make. I decided to mark it with major priority since it doesn't allow me to use hardware acceleration at all (please change it if necessary).

Please also refer to dmesg output and error log (from /sys/class/drm/card0/error) provided. My uname -a is "Linux ThinkPad 4.4.2-gentoo #1 SMP Sat Feb 20 13:17:36 MSK 2016 x86_64 Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz GenuineIntel GNU/Linux". My laptop model is "ThinkPad E550". I use libdrm-2.4.67, mesa-11.1.2, xf86-video-intel-2.99.917_p20160218 (driver). Please ask for any additional information needed.
Comment 1 Vladimir Miloserdov 2016-02-20 13:05:56 UTC
Created attachment 121860 [details]
Error log from /sys/class/drm/card0/error
Comment 2 Chris Wilson 2016-02-20 16:03:59 UTC
Looks like the DMAR hang, please try booting with intel_iommu=igfx_off

*** This bug has been marked as a duplicate of bug 89360 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.