Bug 94246 - Text shadow is rendered incorrectly on Radeon R7 260X
Summary: Text shadow is rendered incorrectly on Radeon R7 260X
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Acceleration/glamor (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-22 11:46 UTC by Steffen
Modified: 2016-03-09 06:30 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Log from Xorg with default options (50.75 KB, text/plain)
2016-02-22 11:46 UTC, Steffen
no flags Details
Log from Xorg with ShadowPrimary enabled (49.04 KB, text/plain)
2016-02-22 11:46 UTC, Steffen
no flags Details
Screenshot with ShadowPrimary enabled (14.96 KB, text/plain)
2016-02-22 11:47 UTC, Steffen
no flags Details
Screenshot with default options (15.30 KB, text/plain)
2016-02-22 11:47 UTC, Steffen
no flags Details
Screenshot with default options (14.96 KB, image/png)
2016-02-22 11:48 UTC, Steffen
no flags Details
Screenshot showing how text shadow is rendered differently depending on options (36.59 KB, image/png)
2016-02-22 11:51 UTC, Steffen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen 2016-02-22 11:46:27 UTC
Created attachment 121882 [details]
Log from Xorg with default options

I noticed some texts were looking blurry depending on my MATE Desktop theme and filed a bug report to MATE team (https://github.com/mate-desktop/mate-themes/issues/104). We discovered that the problem is that my GFX card renders text shadows incorrectly.

Adding this option fixes the problem:
	Option "ShadowPrimary" "true"
This has a side effect of disabling pageflipping. However just disabling pageflipping alone does not fix the problem.

Also if I turn off acceleration completely with:
        Option "Accel" "false"

The problem also is fixed.

Attached: Screenshot and XOrg log of when the problem appears (default options) and when it is fixed (enabling ShadowPrimary)
Comment 1 Steffen 2016-02-22 11:46:58 UTC
Created attachment 121883 [details]
Log from Xorg with ShadowPrimary enabled
Comment 2 Steffen 2016-02-22 11:47:27 UTC
Created attachment 121884 [details]
Screenshot with ShadowPrimary enabled
Comment 3 Steffen 2016-02-22 11:47:44 UTC
Created attachment 121885 [details]
Screenshot with default options
Comment 4 Steffen 2016-02-22 11:48:26 UTC
Created attachment 121886 [details]
Screenshot with default options
Comment 5 Steffen 2016-02-22 11:51:24 UTC
Created attachment 121887 [details]
Screenshot showing how text shadow is rendered differently depending on options

I messed up the previous screenshot attachments, please look at this one instead
Comment 6 Michel Dänzer 2016-02-23 08:21:08 UTC
This is a glamor issue, proposed fix at https://patchwork.freedesktop.org/patch/74719/ .
Comment 7 Michel Dänzer 2016-03-09 06:30:03 UTC
commit a3e681eafa5355b8bb3b099d47983f14f0d5e197
Author: Michel Dänzer <michel.daenzer@amd.com>
Date:   Tue Feb 23 17:19:03 2016 +0900

    glamor: Source pictures are always depth 32


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.