Bug 94315 - AMDGPU 290X Refresh rate issue at 144Hz
Summary: AMDGPU 290X Refresh rate issue at 144Hz
Status: RESOLVED DUPLICATE of bug 93826
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-26 22:50 UTC by Damien
Modified: 2016-02-27 14:05 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xrandr + OSD 139Hz (77.05 KB, text/plain)
2016-02-26 22:50 UTC, Damien
no flags Details
text (33.21 KB, image/jpeg)
2016-02-26 22:51 UTC, Damien
no flags Details
Text2 (36.92 KB, image/jpeg)
2016-02-26 22:51 UTC, Damien
no flags Details
Left pixel repeat (154.92 KB, image/jpeg)
2016-02-26 22:51 UTC, Damien
no flags Details
Left (27.69 KB, image/jpeg)
2016-02-26 22:51 UTC, Damien
no flags Details
290X tested (72.84 KB, image/jpeg)
2016-02-26 22:52 UTC, Damien
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Damien 2016-02-26 22:50:31 UTC
Created attachment 121993 [details]
xrandr + OSD 139Hz

Hello,

I have Arch linux with an asus MG279Q (27 "144Hz) connected in DisplayPort 1.2. Everything worked with Sapphire 7950 and also R9 Fury. 
Unfortunately I have trouble with my Sapphire 290x. I've tested three 290X to be sure it's not an hardware issue. 
Of course freesync is off.
I just tested the combo with multiple users 290 (X and not X) + MG279Q. Sometimes on livecd. Everyone have the issue.

I can't have a real 144Hz with the amdgpu or radeon driver. Everything work only @60Hz or with FGLRX driver.
At 144Hz , i have a bad 139Hz with artifacts : http://reho.st/self/b98c1c955cb7d42c3af6f82ea71bbc94be8aee6a.jpg

Glitches on the left. Blur on all screen, Text glitches...

What i've tried :
- Windows 10 : All works !
- FGLRX : All works @144Hz. But other problems make it difficult to use: in firefox lag among others ... And I love the free driver! Finally ... When he worked with my 7950
- Kernel mainline : Same issue .
- New mode line with cvt 2560 1440 144 and xrandr --newmode : Same issue.
- Contact Sapphire and upload to a new vbios : Same issue and as long as it works on windows it's not their problem...

It can be an incompatibility between the MG279Q and the 290X on linux. But something in FGLRX make my 290X works, but not present on AMDGPU/Radeon driver.

I just tested the combo with multiple users 290 (X and not X) + MG279Q. Sometimes on livecd. Everyone have the issue.

Thanks for your help
Comment 1 Damien 2016-02-26 22:51:00 UTC
Created attachment 121994 [details]
text
Comment 2 Damien 2016-02-26 22:51:12 UTC
Created attachment 121995 [details]
Text2
Comment 3 Damien 2016-02-26 22:51:35 UTC
Created attachment 121996 [details]
Left pixel repeat
Comment 4 Damien 2016-02-26 22:51:53 UTC
Created attachment 121997 [details]
Left
Comment 5 Damien 2016-02-26 22:52:25 UTC
Created attachment 121998 [details]
290X tested
Comment 6 Damien 2016-02-26 22:54:49 UTC
Issue on all kernels + AMDGPU and Radeon driver. But i'm actually on mainline/ AMDGPU CIK

Ok on Catalyst FGLRX.
Comment 7 Alex Deucher 2016-02-27 14:05:21 UTC

*** This bug has been marked as a duplicate of bug 93826 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.