Bug 94346 - WebGL conformance2/textures/misc/copy-texture-image.html fails
Summary: WebGL conformance2/textures/misc/copy-texture-image.html fails
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-01 08:27 UTC by xinghua
Modified: 2019-09-25 18:56 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xinghua 2016-03-01 08:27:31 UTC
Steps:
1. Install latest unstable google chrome, details:
   add "deb http://dl.google.com/linux/chrome/deb/ stable main" to your computer software source list(/etc/apt/sources.list).
   sudo apt-get update
   sudo apt-get install google-chrome-unstable

2. Run chrome in the terminal, you can specify your Mesa driver and run with some options,
   [LD_LIBRARY_PATH=<mesa_lib>:$LD_LIBRARY_PATH LIBGL_DRIVERS_PATH=<mesa_lib>/dri] google-chrome-unstable --enable-unsafe-es3-apis -- use-gl=egl

3. Please check chrome revision ("chrome://version"), it must be newer than #376886

4. Open the link, https://www.khronos.org/registry/webgl/sdk/tests/webgl-conformance-tests.html?version=2.0.0 (should be 2.0.0(beta))

5. Search case "conformance2/textures/misc/copy-texture-image.html", and run this case.

Result: This case will fail. This case succeeds on nvidia driver.

Expected: This case passes on Mesa driver. 

Notes: We test the case on below devices based on Mesa driver, it also fails.
Pixel 2013 - IVB Chromebook, Mesa version 11.0.2
Acer C720 - HSW Chromebook, Mesa version 11.0.2
Acer C910 - BDW Chromebook, Mesa version 11.0.2
Comment 1 xinghua 2016-03-02 02:26:40 UTC
Sorry, in step2, there is a redundant blank of "-- use-gl=egl", please remove it to start the chrome.
[LD_LIBRARY_PATH=<mesa_lib>:$LD_LIBRARY_PATH LIBGL_DRIVERS_PATH=<mesa_lib>/dri] google-chrome-unstable --enable-unsafe-es3-apis --use-gl=egl
Comment 2 xinghua 2016-03-02 02:43:12 UTC
We also use "firefox-trunck + Mesa driver" to test this case, it also fails.
Comment 3 Kenneth Graunke 2016-03-02 21:47:37 UTC
I can confirm this.  Page 160-161 of the ES 3.1 specification changed the rules compared to ES 3.0.  Our error condition (see formats_differ_in_component_sizes in copyteximage()) seems to be implementing the ES 3.0 rules - this may need to be changed.
Comment 4 Mark Janes 2016-03-03 01:53:48 UTC
Removing the tighter 3.0 restriction passes these tests, but then causes Mesa to fail the ES 3.0 conformance suite.  Mesa's 3.0 implementation is automatically promoted to ES3.1 on platforms that support it, and Mesa removes the restriction.

Seems like the two Khronos CTS suites are mutually incompatible.
Comment 5 GitLab Migration User 2019-09-25 18:56:27 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1517.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.