Bug 94449 - Implement the invariant keyword
Summary: Implement the invariant keyword
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: glsl-compiler (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Jason Ekstrand
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 90901 (view as bug list)
Depends on:
Blocks: i965-deqp
  Show dependency treegraph
 
Reported: 2016-03-09 00:55 UTC by Kenneth Graunke
Modified: 2019-03-14 08:40 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Graunke 2016-03-09 00:55:32 UTC
Mesa's GLSL compiler ignores the "invariant" keyword.  This needs to be implemented.

Some tests in dEQP-GLES3.functional.shaders.invariance.* currently fail because of this.  Some pass by luck.  Handling "invariant" correctly should fix all of these.
Comment 1 Kenneth Graunke 2016-03-09 00:56:03 UTC
*** Bug 90901 has been marked as a duplicate of this bug. ***
Comment 2 Kenneth Graunke 2016-03-19 06:56:57 UTC
Jason has patches on the mailing list for this.
Comment 3 Kenneth Graunke 2016-03-25 00:15:27 UTC
commit 4e060d80ff92b7fcf9b54cdd5ed00f549db3f573 and earlier fix this.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.