Bug 94454 - dEQP-GLES3.functional.clipping.point.wide_point_clip* fails
Summary: dEQP-GLES3.functional.clipping.point.wide_point_clip* fails
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: i965-deqp
  Show dependency treegraph
 
Reported: 2016-03-09 01:14 UTC by Kenneth Graunke
Modified: 2016-03-19 06:54 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Graunke 2016-03-09 01:14:36 UTC
The following dEQP tests all fail:

dEQP-GLES2.functional.clipping.point.wide_point_clip

dEQP-GLES3.functional.clipping.point.wide_point_clip
dEQP-GLES3.functional.clipping.point.wide_point_clip_viewport_center
dEQP-GLES3.functional.clipping.point.wide_point_clip_viewport_corner

It looks like extra points are being rendered that should have been clipped away.
Comment 1 Kenneth Graunke 2016-03-09 09:53:38 UTC
I had the result and reference images backwards.  Points that should be rendered, near the very edge, are being clipped away.

Disabling "Viewport XY Clip Test Enable" (GEN6_CLIP_TEST_XY) in 3DSTATE_CLIP makes these tests pass.
Comment 2 Kenneth Graunke 2016-03-11 00:20:11 UTC
I have a 5 patch series which fixes these bugs.  I'll send it to the list as soon as it passes regression testing.
Comment 3 Kenneth Graunke 2016-03-11 01:36:33 UTC
Starting at:
https://lists.freedesktop.org/archives/mesa-dev/2016-March/109702.html
Comment 4 Kenneth Graunke 2016-03-19 06:54:34 UTC
Fixed in master with:

commit 88d28aa4d9edec33ef7bcf1f56b77fbb756a24f8
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Thu Mar 10 14:36:25 2016 -0800

    i965: Stop XY clipping point and line primitives.

commit 0de64ab7881cc4d343fecf8a2b5b9b9ca7b34416
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Thu Mar 10 15:30:36 2016 -0800

    i965: Scissor to the viewport when rendering points/lines.

commit d000a4989f66921832a33742ea07fa191393231b
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Thu Mar 10 16:04:01 2016 -0800

    i965: Include the viewport in the scissor rectangle.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.