Bug 9446 - [r300] running compiz or 3d app locks up/freezes X after some time using r300 driver
[r300] running compiz or 3d app locks up/freezes X after some time using r300...
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/r300
unspecified
x86 (IA32) Linux (All)
: high major
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-25 11:34 UTC by Cyrill Helg
Modified: 2011-03-08 11:18 UTC (History)
3 users (show)

See Also:


Attachments
dmesg of my system (15.03 KB, text/plain)
2006-12-25 11:35 UTC, Cyrill Helg
Details
The xorg.conf with fastest options. (4.35 KB, text/plain)
2006-12-25 11:35 UTC, Cyrill Helg
Details
the Xorg.conf log file (52.94 KB, text/plain)
2006-12-25 11:36 UTC, Cyrill Helg
Details
debug output (15.14 KB, text/plain)
2006-12-25 16:16 UTC, Cyrill Helg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cyrill Helg 2006-12-25 11:34:51 UTC
I'm having a problem with Xorg from cvs and mesa built from cvs. When I'm
running beryl on it for some time my X hard locks. I can access the machine with
ssh but can't terminate X.

The logs say nothing special after it locked up.

The problem must be introduced with a change in "recent" mesa/xorg code, because
when I downgrade mesa to 6.5.2 my system seems to be stable. (But its r300 is
not as fast as with latest code so I'd like to use more recent version)

First I thought it could be an option in xorg.conf but I tried a lot of
different combinations with no luck.
Comment 1 Cyrill Helg 2006-12-25 11:35:16 UTC
Created attachment 8212 [details]
dmesg of my system
Comment 2 Cyrill Helg 2006-12-25 11:35:51 UTC
Created attachment 8213 [details]
The xorg.conf with fastest options.
Comment 3 Cyrill Helg 2006-12-25 11:36:13 UTC
Created attachment 8214 [details]
the Xorg.conf log file
Comment 4 Jerome Glisse 2006-12-25 11:58:48 UTC
Could you enable debugging output of drm an attach log
generated once a lockup happened. Could you also gitbisec
mesa try finding if there is a particuliar commit responsible
for this (but i don't think so as there haven't been so
much change since 6.5.2).
Comment 5 Cyrill Helg 2006-12-25 12:15:00 UTC
I was wrong: Even with mesa 6.5.2 my system locks up.
Comment 6 Cyrill Helg 2006-12-25 12:16:25 UTC
Hmm where exactly do I need to enable debug? When compiling what or can I set en
env variable?
Comment 7 Cyrill Helg 2006-12-25 13:11:00 UTC
Ok now I downgraded to xorg 7.1 and mesa 6.5.1. (stable stuff on gentoo)

But still my system locked up. I found a good way to lock it up: Starting beryl
+ a 3d app like googlearth.

The only thing the log said was:

(II) XAA: Evicting pixmaps
Comment 8 Giacomo Perale 2006-12-25 13:32:48 UTC
Same problem here, with mesa 6.5.2 and xorg-server 1.1.99.903
Comment 9 Jerome Glisse 2006-12-25 13:34:45 UTC
You enable debug by echo 1 > /sys/module/drm/parameters/debug
or while loading drm module modprobe drm debug=1
Comment 10 Cyrill Helg 2006-12-25 13:50:39 UTC
(In reply to comment #9)
> You enable debug by echo 1 > /sys/module/drm/parameters/debug
> or while loading drm module modprobe drm debug=1

Ok I will now upgrade again and then try to get some more information from the
log file right?
Comment 11 Jerome Glisse 2006-12-25 14:44:18 UTC
drm log will be in your message logfile likely /var/log/message
Comment 12 Cyrill Helg 2006-12-25 16:16:55 UTC
Created attachment 8215 [details]
debug output

I crashes especially (or even only) under "heavy" load...
Comment 13 Giacomo Perale 2007-02-03 05:52:27 UTC
I just had a similar crash with googleearth (on metacity, without compiz/beryl), so it seems that the problem is driver-related.
Comment 14 Cyrill Helg 2007-02-05 03:33:28 UTC
This problem still exists (xorg 7.2). Is there anything I can do to help solving this problem? Do you need some additional information?
Comment 15 Giacomo Perale 2007-02-05 03:42:38 UTC
I opened another bug report, because I'm not sure that the problem with googleearth is the same reported here (https://bugs.freedesktop.org/show_bug.cgi?id=9861). Could you check if you have that problem too? You could also try with the instructions of http://wiki.x.org/wiki/DebuggingTheXserver. To obtain the backtrace I had to attach gdb to the X process AFTER the lockup.
Comment 16 Cyrill Helg 2007-10-25 03:51:49 UTC
As far as I can judge this a lot of people are having this freeze problem. It even happens without running compiz. The problem still exists in the latest versions of xorg-server.

Is any dev taking this serious? Do you need more information or anything we can do to get this solved soon?
Comment 17 Giacomo Perale 2007-10-25 06:42:55 UTC
Problem disappeared here with the upgrade to xorg-server 1.4, mesa 7.0.1 and xf86-video-ati 6.7.1xx (using compiz/compiz-fusion 0.5.2 and then 0.6.2/0.6.0).
Comment 18 Erkin Bahceci 2007-10-25 17:58:12 UTC
I have the same problem with the open source drivers and with Xorg server 1.3 (Ubuntu 7.10), like many other people on this bug report:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/108527
GoogleEarth usually makes it happen faster.
Comment 19 Michel Dänzer 2007-10-26 01:38:49 UTC
(In reply to comment #18)
> I have the same problem [...]

That's quite a bold statement unfortunately - there are countless possible causes for lockups, all resulting in similar if not the same symptoms.

As for this particular report, the first thing to do is always to rule out a configuration issue. In particular, Option "GARTSize" "64" is a candidate, try reducing that to 32 (see bug 12612). Option "DynamicClocks" is another candidate.

If disabling these and other options doesn't help, the best thing to do is to try and isolate the version of Mesa, xf86-video-ati, drm or xserver that introduced it or to try and isolate a way to reproduce the problem that is as specific as possible.
Comment 20 Adam K Kirchhoff 2007-10-26 02:39:50 UTC
Back in March of this year I started having a problem with lockups on my PCIe box when running most/many 3D applications (including GoogleEarth) if I didn't disable SilkenMouse.  From my testing, this seemed to be introduced with the merged from the vbo-0.2 branch.  Please try disabling that option and see if it makes a difference.
Comment 21 Michel Dänzer 2007-10-26 03:12:08 UTC
(In reply to comment #20)
> Back in March of this year I started having a problem with lockups on my PCIe
> box when running most/many 3D applications (including GoogleEarth) if I didn't
> disable SilkenMouse.

Is that still necessary with current xf86-video-ati Git?
Comment 22 Cyrill Helg 2007-10-26 06:58:20 UTC
(In reply to comment #20)
> Back in March of this year I started having a problem with lockups on my PCIe
> box when running most/many 3D applications (including GoogleEarth) if I didn't
> disable SilkenMouse.  From my testing, this seemed to be introduced with the
> merged from the vbo-0.2 branch.  Please try disabling that option and see if it
> makes a difference.
> 

SilkenMouse is a config option in xorg.conf, how exactly? Btw: Where can I get a list of all options?
Comment 23 Adam K Kirchhoff 2007-10-26 12:48:08 UTC
Michel, actually this does not appear to be necessary any more.  Not sure when it was fixed :-)

Cyrill, in the Device section, you'd add the line:

  Option        "SilkenMouse" "0"

That will disable SilkenMouse
Comment 24 Jerome Glisse 2011-03-08 11:18:41 UTC
Closing