Bug 94624 - Xorg using 100% CPU since eb5108b8
Summary: Xorg using 100% CPU since eb5108b8
Status: RESOLVED DUPLICATE of bug 94596
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-19 12:22 UTC by Bernd Steinhauser
Modified: 2016-03-21 17:42 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (58.72 KB, text/plain)
2016-03-19 12:22 UTC, Bernd Steinhauser
no flags Details

Description Bernd Steinhauser 2016-03-19 12:22:21 UTC
Created attachment 122428 [details]
Xorg.0.log

GPU: Kaveri
Kernel: 4.4.5
xorg-server: 1.18.2
DDX: xf86-video-ati, 7.6.1

Since updating from xorg-server 1.18.1 to 1.18.2, Xorg will use 100% of one CPU constantly.
bisecting the issue led to the commit

commit eb5108b87017128f394ae31b5b7cd85dd8819bca
Author: Michel Dänzer
Date:   Wed Feb 24 16:52:58 2016 +0900

    present: Requeue if flip driver hook fails and target MSC not reached
    
    For flipping, we wait for the MSC before the target MSC and then call
    the driver flip hook. If the latter fails, we have to wait for the
    target MSC before falling back to a copy, or else it's executed too
    early.
    
    Fixes glxgears running at unbounded framerate (not synchronized to the
    refresh rate) in fullscreen if the driver flip hook fails.
    
    Reviewed-by: Chris Wilson
    Signed-off-by: Michel Dänzer
    (cherry picked from commit e7a35b9e16aa12970908f5d55371bb1b862f8f24)

The Xorg.0.log looks clean, but I'll attach it anyway for further info.
I tried with PageFlip (and TearFree) disabled, but that didn't change the outcome.
Reverting the commit on top of 1.18.2 leads to normal behaviour.
Comment 1 Olivier Fourdan 2016-03-21 09:53:10 UTC
Dupe of bug 94596 ?
Comment 2 Bernd Steinhauser 2016-03-21 17:42:51 UTC
Yes, certainly looks like it, thanks for the pointer.

I did perform a search, but didn't find that one.

*** This bug has been marked as a duplicate of bug 94596 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.