Bug 94626 - Broadwell: OpenGL 3.1+ corruption
Summary: Broadwell: OpenGL 3.1+ corruption
Status: RESOLVED NOTOURBUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 11.2
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-19 15:32 UTC by florian
Modified: 2016-03-23 02:11 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description florian 2016-03-19 15:32:50 UTC
My Acer C740 renders severly corrupted frames in a deferred renderer (render to texture and then from texture to screen). It looks like the red component is increased for about half of the pixels. This happens only on OpenGL 3.1+ contexts and ES 3.1 contexts, both in 11.1 and 11.2-rc3.
glxgears stays black under the same conditions, when setting the OpenGL version via environment variable.
I can provide test cases if someone gives me some pointers what you want to see (screenshots, texture dumps, hello triangle, render to/from texture). I don't really have an idea what kind of feature is likely to be the culprit.

Both test program work fine on (ES) 3.0.
Comment 1 Kenneth Graunke 2016-03-19 18:31:02 UTC
Can you provide an apitrace of the application?  A screenshot showing how you expect it to look would be nice too.
Comment 2 florian 2016-03-22 16:39:35 UTC
While trying to create a minimal example for an api trace, I discovered that this is not a bug but a mistake on my side. Turns out there was an uninitialized shader variable.

It is a bit strange that changing the context version affects the behavior here when the shader code is the same.

Anyway, sorry for the noise.
Comment 3 florian 2016-03-22 16:42:12 UTC
FWIW, this mistake has not led to any issues with other drivers on different platforms.
Comment 4 Kenneth Graunke 2016-03-23 02:11:25 UTC
I think most vendors zero uninitialized values (it's basically free on nvidia), while we leave them uninitialized (as there's an actual cost).

Strange that it would depend on the context version though.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.