Bug 94657 - [llvmpipe] [softpipe] piglit arb_texture_view-getteximage-srgb regression
Summary: [llvmpipe] [softpipe] piglit arb_texture_view-getteximage-srgb regression
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2016-03-22 02:16 UTC by Vinson Lee
Modified: 2016-03-24 17:25 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2016-03-22 02:16:15 UTC
mesa: 1e8435ce0cce671024ebf9c5465ea8bdcb563b69 (master 11.3.0-devel)

$ ./bin/arb_texture_view-getteximage-srgb -auto
Wrong color for GL_SRGB8_ALPHA8 texture view.
Expected 0xff0000ff but found 0x0000ffff 
PIGLIT: {"result": "fail" }

a8eea696b8966d119e213d532158f63c5b280740 is the first bad commit
commit a8eea696b8966d119e213d532158f63c5b280740
Author: Nicolai Hähnle <nicolai.haehnle@amd.com>
Date:   Mon Mar 14 15:33:34 2016 -0500

    st/mesa: honour sized internal formats in st_choose_format (v2)
    
    The bitcasting which is possible with shader images (and texture views?)
    requires that when the user specifies a sized internal format for a
    texture, we really allocate that format. To this end:
    
    (1) find_exact_format should ignore sized internal formats and
    
    (2) some of the entries in the mapping table corresponding to sized
        internal formats are reordered to use an RGBA format instead of
        a BGRA one.
    
    This fixes arb_shader_image_load_store-bitcast in the (work in progress)
    ARB_shader_image_load_store implementation for radeonsi.
    
    v2: don't change the mapping of GL_RGB10: the change caused a regression
        because it preferred a format with an alpha channel, and GL_RGB10
        is not among the supported formats for shader images
    
    Reviewed-by: Marek Olšák <marek.olsak@amd.com>

:040000 040000 572b09e6a4cec5c7267d43ecfe6e497775faf753 77f5d9b5f75285074cc89652de547f5129ea1b99 M	src
bisect run success
Comment 1 Nicolai Hähnle 2016-03-23 20:24:59 UTC
I missed that test somehow, sorry for that. There's a fix here: https://patchwork.freedesktop.org/patch/78118/
Comment 2 Nicolai Hähnle 2016-03-24 17:25:49 UTC
Fix in master, commit 6b763c0


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.