Bug 94659 - excessive rasterisation of some PDFs
Summary: excessive rasterisation of some PDFs
Status: RESOLVED MOVED
Alias: None
Product: cairo
Classification: Unclassified
Component: win32 backend (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: cairo-bugs mailing list
QA Contact: cairo-bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-22 12:42 UTC by Pierre Ossman
Modified: 2018-08-25 13:29 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Ossman 2016-03-22 12:42:29 UTC
We're switching over from SumatraPDF to Poppler/Cairo as the software to handle PDF printing on Windows. Unfortunately we are seeing some regressions in that some documents are getting rasterised rather than being sent to the printer in a vector format.

Two examples:

http://image.guardian.co.uk/sys-files/Guardian/documents/2004/11/11/lemon_jelly.pdf
http://www.princexml.com/samples/invoice/invoicesample.pdf

Taken from:

https://wiki.gnome.org/Apps/Evince/Testing
http://www.princexml.com/samples/

The problem seems to be specific to the Win32 backend as pdftocairo with the SVG backend works fine.
Comment 1 GitLab Migration User 2018-08-25 13:29:42 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/cairo/cairo/issues/32.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.