Bug 94671 - [radeonsi] Blue-ish textures in Shadow of Mordor
Summary: [radeonsi] Blue-ish textures in Shadow of Mordor
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: All Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-23 10:33 UTC by Jan Ziak
Modified: 2016-03-24 17:26 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Screenshot: AMD OpenGL driver (440.21 KB, image/png)
2016-03-23 10:45 UTC, Jan Ziak
Details
Screenshot: Mesa radeonsi OpenGL (412.28 KB, image/png)
2016-03-23 10:46 UTC, Jan Ziak
Details
Screenshot: Mesa radeonsi OpenGL - patched (417.68 KB, image/png)
2016-03-23 23:04 UTC, Jan Ziak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Ziak 2016-03-23 10:33:10 UTC
Red fabric/cloth in Shadow of Mordor benchmark is rendered in blue color.

mesa-git built date: 2016-Mar-22 07:16:38 CET
Comment 1 Jan Ziak 2016-03-23 10:45:19 UTC
Created attachment 122494 [details]
Screenshot: AMD OpenGL driver
Comment 2 Jan Ziak 2016-03-23 10:46:09 UTC
Created attachment 122495 [details]
Screenshot: Mesa radeonsi OpenGL
Comment 3 Jan Ziak 2016-03-23 10:48:07 UTC
Further information:

- Linux kernel 4.5.0
- Kernel module: radeon

$ glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD HAWAII (DRM 2.43.0, LLVM 3.8.0)
OpenGL core profile version string: 4.1 (Core Profile) Mesa 11.3.0-devel (git-530593d)
Comment 4 Ernst Sjöstrand 2016-03-23 11:13:41 UTC
I saw this too with Amdgpu Fury.
Comment 5 Nicolai Hähnle 2016-03-23 14:06:54 UTC
Thank you for the report.

I suspect some of the BGR <-> RGB changes for shader image bitcasts are responsible. Could one of you please provide an apitrace that shows the problem? That would be very helpful.
Comment 6 Jan Ziak 2016-03-23 19:18:00 UTC
(In reply to Nicolai Hähnle from comment #5)
> Thank you for the report.
> 
> I suspect some of the BGR <-> RGB changes for shader image bitcasts are
> responsible. Could one of you please provide an apitrace that shows the
> problem? That would be very helpful.

Running Shadow of Mordor under apitrace 6.1 is very slow. I didn't run the benchmark because the ingame menu screen wasn't responding. However, the menu screen already has the blue-ish tint that shouldn't be there.

The trace is quite large: 392 MB uncompressed, 219 MB compressed with xz.

Do you still want the trace despite its size?

If not, do you want me to run apitrace on AMD's Opengl library and then perform "apitrace diff ShadowOfMordor-radeonsi.trace ShadowOfMordor-amd.trace"?
Comment 7 Nicolai Hähnle 2016-03-23 20:27:54 UTC
Hi Jan! First, please try this patch which fixes a similar bug: https://patchwork.freedesktop.org/patch/78118/

If that doesn't fix the problem: I'd appreciate if you could upload the apitrace somewhere (Dropbox, Google Drive, etc.). A diff is not going to be useful.

But first, try if the problem is already fixed with the patch above :)
Comment 8 Jan Ziak 2016-03-23 23:04:20 UTC
(In reply to Nicolai Hähnle from comment #7)
> Hi Jan! First, please try this patch which fixes a similar bug:
> https://patchwork.freedesktop.org/patch/78118/
> 
> If that doesn't fix the problem: I'd appreciate if you could upload the
> apitrace somewhere (Dropbox, Google Drive, etc.). A diff is not going to be
> useful.
> 
> But first, try if the problem is already fixed with the patch above :)

The patch works!
Comment 9 Jan Ziak 2016-03-23 23:04:58 UTC
Created attachment 122511 [details]
Screenshot: Mesa radeonsi OpenGL - patched
Comment 10 Nicolai Hähnle 2016-03-24 17:26:00 UTC
Fixed in Mesa master, commit 6b763c0


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.