Bug 94780 - GPU HANG: ecode 8:0:0x85dffffb, in Xorg [398], reason: Ring hung, action: reset
Summary: GPU HANG: ecode 8:0:0x85dffffb, in Xorg [398], reason: Ring hung, action: reset
Status: CLOSED DUPLICATE of bug 89360
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
: 92314 94493 95512 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-04-01 15:57 UTC by Marcin Mielniczuk
Modified: 2017-07-24 22:42 UTC (History)
7 users (show)

See Also:
i915 platform: BDW
i915 features: GPU hang


Attachments
The dmesg output (55.68 KB, text/plain)
2016-04-01 15:58 UTC, Marcin Mielniczuk
no flags Details
/var/log/Xorg.0.log (27.45 KB, text/plain)
2016-04-01 15:59 UTC, Marcin Mielniczuk
no flags Details
/sys/class/drm/card0/error (2.72 MB, text/plain)
2016-04-01 16:00 UTC, Marcin Mielniczuk
no flags Details
journald log (8.81 KB, text/plain)
2016-05-25 18:48 UTC, Alexey Kharlamov
no flags Details
/sys/class/drm/card0/error (526.58 KB, text/plain)
2016-05-25 22:09 UTC, Alexey Kharlamov
no flags Details
corresponding dmesg (55.63 KB, text/plain)
2016-05-25 22:09 UTC, Alexey Kharlamov
no flags Details
corresponding Xorg.log (23.61 KB, application/x-trash)
2016-05-25 22:11 UTC, Alexey Kharlamov
no flags Details
got more verbose dmesg this time (80.13 KB, text/plain)
2016-05-26 08:50 UTC, Alexey Kharlamov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Mielniczuk 2016-04-01 15:57:54 UTC
uname -a:
 Linux arch 4.1.20-1-lts #1 SMP Fri Mar 18 17:26:44 CET 2016 x86_64 GNU/Linux

I'm using Cinnamon. When launching Netbeans, I experience a hang. After that the GPU acceleration gets disabled.
Comment 1 Marcin Mielniczuk 2016-04-01 15:58:45 UTC
Created attachment 122665 [details]
The dmesg output
Comment 2 Marcin Mielniczuk 2016-04-01 15:59:16 UTC
Created attachment 122666 [details]
/var/log/Xorg.0.log
Comment 3 Marcin Mielniczuk 2016-04-01 16:00:00 UTC
Created attachment 122667 [details]
/sys/class/drm/card0/error
Comment 4 Marcin Mielniczuk 2016-04-11 12:50:23 UTC
I'm able to reproduce this in another usecase: opening a file in Eclipse. This seems to affect Java applications in some special way
Comment 5 Marcin Mielniczuk 2016-04-12 15:15:42 UTC
This is my whole setup (including HW setup, which was missing)

$ inxi -F
System:    Host: arch Kernel: 4.1.21-1-lts x86_64 (64 bit)
           Desktop: Cinnamon 2.8.8  Distro: Arch Linux
Machine:   System: ASUSTeK (portable) product: X555LB v: 1.0
           Mobo: ASUSTeK model: X555LB v: 1.0
           Bios: American Megatrends v: X555LB.204 date: 01/13/2015
CPU:       Dual core Intel Core i5-5200U (-HT-MCP-) cache: 3072 KB 
           clock speeds: max: 2700 MHz 1: 2200 MHz 2: 2200 MHz 3: 2200 MHz
           4: 2200 MHz
Graphics:  Card-1: Intel Broadwell-U Integrated Graphics
           Card-2: NVIDIA GM108M [GeForce 940M]
           Display Server: X.Org 1.18.3 driver: intel
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
           GLX Version: 3.0 Mesa 11.2.0
Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller
           driver: snd_hda_intel
           Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.1.21-1-lts
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169
           IF: enp2s0 state: up speed: 100 Mbps duplex: full
           mac: 1c:b7:2c:0c:e6:7d
           Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
           driver: ath9k
           IF: wlp3s0 state: down mac: 40:e2:30:f1:3d:73
Drives:    HDD Total Size: 128.0GB (22.9% used)
           ID-1: /dev/sda model: LITEONIT_LCS size: 128.0GB
Partition: ID-1: / size: 73G used: 24G (34%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/sda4
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 143 Uptime: 8 min Memory: 1410.7/7889.2MB
           Client: Shell (fish) inxi: 2.2.38
Comment 6 yann 2016-05-18 17:14:15 UTC
*** Bug 92314 has been marked as a duplicate of this bug. ***
Comment 7 yann 2016-05-18 17:15:31 UTC
*** Bug 94493 has been marked as a duplicate of this bug. ***
Comment 8 yann 2016-05-24 12:25:01 UTC
*** Bug 95512 has been marked as a duplicate of this bug. ***
Comment 9 Alexey Kharlamov 2016-05-25 18:36:49 UTC
Able to reproduce it (not saved the card dump yet -- system hangs)

Reproducible: 50/50 when I launch some intensive load (like package compilation)
Comment 10 Alexey Kharlamov 2016-05-25 18:48:53 UTC
Created attachment 124089 [details]
journald log
Comment 11 Alexey Kharlamov 2016-05-25 22:09:21 UTC
Created attachment 124092 [details]
/sys/class/drm/card0/error
Comment 12 Alexey Kharlamov 2016-05-25 22:09:51 UTC
Created attachment 124093 [details]
corresponding dmesg
Comment 13 Alexey Kharlamov 2016-05-25 22:11:17 UTC
Created attachment 124094 [details]
corresponding Xorg.log
Comment 14 Alexey Kharlamov 2016-05-25 22:13:17 UTC
I've tried to use xorg modesetting driver, but it seems to cause gpu hang on xorg startup.
Comment 15 Alexey Kharlamov 2016-05-26 08:50:31 UTC
Created attachment 124108 [details]
got more verbose dmesg this time
Comment 16 Alexey Kharlamov 2016-05-27 16:10:10 UTC
I have found out that hangs disappear when I disable VT-d in BIOS.
Comment 17 Jari Tahvanainen 2017-03-09 12:17:36 UTC
Marcin, Alexey - I'm sorry about this delay on getting back to you. Is this problem still valid? Have you tried the newest kernel, preferable generated from drm-tip? If yes then please provide new dmesg and card0/error data.
Comment 18 Chris Wilson 2017-03-09 13:04:33 UTC

*** This bug has been marked as a duplicate of bug 89360 ***
Comment 19 Marcin Mielniczuk 2017-04-03 20:57:21 UTC
I can't reproduce it anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.