Bug 94795 - Problem in Gstreamer SDK tutorial #1
Summary: Problem in Gstreamer SDK tutorial #1
Status: NEW
Alias: None
Product: GStreamer SDK
Classification: Unclassified
Component: Website (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: bugs
QA Contact:
Depends on:
Reported: 2016-04-01 23:33 UTC by Ben Schleimer
Modified: 2018-10-11 07:17 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Description Ben Schleimer 2016-04-01 23:33:19 UTC
I worked through the first SDK tutorial at http://docs.gstreamer.com/pages/viewpage.action?pageId=327735 using gstreamer 1.6.3 on Ubuntu 15.05.

The command:

gst_parse_launch ("playbin2 uri=http://docs.gstreamer.com/media/sintel_trailer-480p.webm", NULL);

failed because playbin2 doesn't exist in 1.0.
It worked after I spent awhile scratching my head.
Once I realized that I needed changed it to gst_parse_launch("playbin ..."), it played correctly.

There have been other people with the same problem.

Comment 1 Ben Schleimer 2016-04-02 19:16:11 UTC
Hi, me again. 
  Tutorial 3 has a problem with gst_pad_get_caps() in pad_added_handler().
There are ports of the tutorials at https://cgit.freedesktop.org/~slomo/gst-sdk-tutorials/tree/gst-sdk/tutorials

Please change the tutorials at http://docs.gstreamer.com/display/GstSDK/Basic+tutorials to these new tutorials that work for gstreamer 1.0

Thank you for your time,

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.