Bug 94807 - No image on ASUS Transformer Book T100HA DSI display
Summary: No image on ASUS Transformer Book T100HA DSI display
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-03 21:28 UTC by Wong Yong Jie
Modified: 2017-06-23 14:24 UTC (History)
2 users (show)

See Also:
i915 platform: BSW/CHT
i915 features: display/DSI


Attachments
kernel.log (138.87 KB, text/plain)
2016-04-03 21:28 UTC, Wong Yong Jie
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wong Yong Jie 2016-04-03 21:28:09 UTC
Created attachment 122688 [details]
kernel.log

On my ASUS Transformer Book T100HA, the built in DSI display fails to display any image right after KMS takes over from efifb. The backlight remains on.

Please see attached for kernel log (drm.debug=0xe).

I am unable to obtain a VBIOS dump. Kernel says:
0:02.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xe725

Steps to reproduce the issue:
1) Just boot the device.

How often does the steps listed above trigger the issue?
Always.

The following information about your system:
-- system architecture: x86-64
-- kernel version: 4.6.0-994-generic (drm-intel-nightly from 2016-04-02)
-- Linux distribution: Ubuntu 15.10
-- Machine or mother board model: ASUS Transformer Book T100HA
-- Display connector: DSI
Comment 1 Wong Yong Jie 2016-04-03 21:41:07 UTC
Interestingly, this allows the display to have an image:

# X &
# DISPLAY=:0 xrandr
Screen 0: minimum 8 x 8, current 800 x 1280, maximum 32767 x 32767
DSI1 connected 800x1280+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   800x1280      60.10*+
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
# DISPLAY=:0 xrandr --output DSI1 --off
# DISPLAY=:0 xrandr --output DSI1 --auto
# DISPLAY=:0 xterm

(xterm displays on screen)
Comment 2 Jari Tahvanainen 2017-03-09 12:06:31 UTC
yjwong92@gmail.com - I'm really sorry about this delay until getting back to you. Are you still seeing this problem with the latest drm-tip and/or Ubuntu? If this is still valid with the newest kernel please provide new dmesg and check out also card0/error data and attach that if applicable ($ cat /sys/class/drm/card0/error | bz2 > error.bz2).

Or should I assume that this is fixed due to comment 1?
Comment 3 Jani Nikula 2017-03-23 13:08:17 UTC
I suspect this may be fixed in either v4.11-rc3 or drm-tip branch of https://cgit.freedesktop.org/drm/drm-tip. Please retest.
Comment 4 Ricardo 2017-06-23 14:24:07 UTC
due to lack of response from the verification I'm closing this bug as fixed according to last comment. If the issue remains please open a new bug with


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.