Bug 94835 - Increase fragment shader sample limits from 16 to 32 (AMD Linux - Mesa/RadeonSi)
Summary: Increase fragment shader sample limits from 16 to 32 (AMD Linux - Mesa/RadeonSi)
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: All Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 94705
  Show dependency treegraph
 
Reported: 2016-04-06 07:05 UTC by Edwin Smith (Feral Interactive)
Modified: 2016-04-07 18:18 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Edwin Smith (Feral Interactive) 2016-04-06 07:05:48 UTC
Please increase fragment shader sample limits from 16 to 32. This is causing serious issues with Company Of Heroes 2 as the engine needs more than 16 samplers to correctly render the floor.

Please note: Mesa support 32 samplers with their Intel drivers, but not AMD. See GL_MAX_TEXTURE_IMAGE_UNITS_ARB in https://people.freedesktop.org/~imirkin/glxinfo/glxinfo.html

Feral can provide a Steam key to active Mesa engineers working on this issue if that would help their progress. YOU should be abel to use Intel Mesa as a reference as that draws correctly as it has a higher texture sampler limit.
Comment 1 Edwin Smith (Feral Interactive) 2016-04-06 07:10:38 UTC
Added links to:

94705 - CoH2 specific bug logged by an end user showing the side effect if the sampler limit is reached on AMD. 

91951 - Unsure if exactly the same issue but potentially a similar root cause. This was logged agains ARMA 3 developer by another developer so I have no insight other than finding the bug when looking for duplicates before logging.
Comment 2 Ilia Mirkin 2016-04-06 13:47:29 UTC
(In reply to Edwin Smith from comment #0)
> Feral can provide a Steam key to active Mesa engineers working on this issue
> if that would help their progress.

A little bit off-topic, but would such a key be provided for people working on drivers other than radeonsi? [r600 and nvc0 come to mind]

> YOU should be abel to use Intel Mesa as a
> reference as that draws correctly as it has a higher texture sampler limit.

By the way, that's only true for Haswell and newer. Ivybridge (gen7) is limited to 16, at least on Mesa.
Comment 3 Nicolai Hähnle 2016-04-06 17:03:37 UTC
I have a preliminary patch set for this, but I still need to put it through its testing paces.
Comment 4 Edwin Smith (Feral Interactive) 2016-04-07 12:46:25 UTC
(In reply to Ilia Mirkin from comment #2)
> (In reply to Edwin Smith from comment #0)
> > Feral can provide a Steam key to active Mesa engineers working on this issue
> > if that would help their progress.
> 
> A little bit off-topic, but would such a key be provided for people working
> on drivers other than radeonsi? [r600 and nvc0 come to mind]

Any reasonable request from an engineer working on this issue requesting a key to help with their efforts will be considered.
Comment 5 Nicolai Hähnle 2016-04-07 18:18:26 UTC
Implemented in Git master commit 2abe4f8d7dcdcff75c28958e1a691ebf6cdee1ac


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.