Bug 94906 - [bdw] GPU crash in Enter the Gungeon (steam game)
Summary: [bdw] GPU crash in Enter the Gungeon (steam game)
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 11.1
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-12 20:47 UTC by jean.wicht
Modified: 2016-06-12 20:38 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg (23.89 KB, application/bzip2)
2016-04-12 20:47 UTC, jean.wicht
Details
/sys/class/drm/card0/error (45.59 KB, application/bzip2)
2016-04-12 20:47 UTC, jean.wicht
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jean.wicht 2016-04-12 20:47:09 UTC
Created attachment 122883 [details]
dmesg

GPU always crashes after 1-3 minutes in Enter the Gungeon (steam game).

Uname -m: x86_64
OS: Fedora 23
Kernel: 4.4.6-301.fc23.x86_64
mesa: 11.1.0-2.20151218.fc23.x86_64
Xorg: 1.18.3-1.fc23.x86_64
Xorg-intel: 2.99.917-19.20151206.fc23.x86_64

Machine is Asus UX305-FA with Intel Broadwell
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)


I've attached /sys/class/drm/card0/error and dmesg using drm.debug=0xe kernel option.
Comment 1 jean.wicht 2016-04-12 20:47:57 UTC
Created attachment 122884 [details]
/sys/class/drm/card0/error
Comment 2 jean.wicht 2016-04-13 21:09:52 UTC
I forgot to say that only the game crashes. X is fine. The laptop runs fine after that too.


I've noticed my error code, 0x85dffffb, is reported in many bugs already. It seems to be often recommended to add intel_iommu=igfx_off to the kernel options. I've just tried, it doesn't help.


[   93.922782] [drm] stuck on render ring
[   93.924824] [drm] GPU HANG: ecode 8:0:0x85dffffb, in EtG.x86 [2294], reason: Ring hung, action: reset
[   93.926790] drm/i915: Resetting chip after gpu hang
[   99.931418] [drm] stuck on render ring
[   99.933597] [drm] GPU HANG: ecode 8:0:0x85dffffb, in EtG.x86 [2294], reason: Ring hung, action: reset
[   99.935822] drm/i915: Resetting chip after gpu hang
Comment 3 jean.wicht 2016-04-14 19:12:10 UTC
Just updated to Fedora 24. Now running
kernel: 4.5.0-302.fc24.x86_64
mesa: 1.2.0-0.devel.13.24ea81a

It didn't help, the game is still crashing
Comment 4 jean.wicht 2016-06-02 10:23:19 UTC
Now running:

kernel: 4.5.5-300.fc24.x86_64
mesa: 11.2.1-1.20160501.fc24.x86_64
      OpenGL core profile version string: 3.3 (Core Profile) Mesa 11.2.1 (git-79b0e13)

Game does crash less, it's somewhat playable.

There is now a kernel trace when it does tough. Don't know if it's useful:

43072.961677] [drm] stuck on render ring
[43072.964322] [drm] GPU HANG: ecode 8:0:0x84df3c04, in EtG.x86_64 [22360], reason: Ring hung, action: reset
[43072.964360] ------------[ cut here ]------------
[43072.964402] WARNING: CPU: 0 PID: 21845 at drivers/gpu/drm/i915/intel_display.c:11440 intel_mmio_flip_work_func+0x47c/0x490 [i915]()
[43072.964404] WARN_ON(__i915_wait_request(mmio_flip->req, mmio_flip->crtc->reset_counter, false, NULL, &mmio_flip->i915->rps.mmioflips))
[43072.964406] Modules linked in:
[43072.964408]  snd_usb_audio snd_usbmidi_lib snd_rawmidi cdc_ether usbnet r8152 mii rfcomm ccm fuse nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_broute bridge stp llc ebtable_nat ip6table_mangle ip6table_raw ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_security iptable_mangle iptable_raw iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_security ebtable_filter ebtables ip6table_filter ip6_tables binfmt_misc bnep vfat fat arc4 iwlmvm intel_rapl mac80211 x86_pkg_temp_thermal coretemp kvm_intel kvm iwlwifi asus_nb_wmi btusb snd_soc_rt5640 iTCO_wdt asus_wmi snd_hda_codec_conexant iTCO_vendor_support snd_hda_codec_generic snd_hda_codec_hdmi uvcvideo btrtl snd_soc_rl6231
[43072.964456]  snd_hda_intel sparse_keymap cfg80211 btbcm snd_hda_codec snd_soc_core irqbypass btintel videobuf2_vmalloc crct10dif_pclmul videobuf2_memops crc32_pclmul videobuf2_v4l2 videobuf2_core bluetooth ghash_clmulni_intel snd_hda_core videodev snd_hwdep snd_compress i2c_i801 snd_pcm_dmaengine ac97_bus snd_seq snd_seq_device joydev media snd_pcm rfkill lpc_ich mei_me processor_thermal_device intel_soc_dts_iosf mei snd_timer snd shpchp soundcore elan_i2c wmi int3403_thermal i2c_designware_platform int3402_thermal int3400_thermal acpi_als spi_pxa2xx_platform i2c_designware_core int340x_thermal_zone tpm_crb acpi_thermal_rel snd_soc_sst_acpi kfifo_buf snd_soc_sst_match industrialio asus_wireless acpi_pad tpm_tis hid_logitech_hidpp i915 i2c_algo_bit drm_kms_helper crc32c_intel drm serio_raw sdhci_acpi
[43072.964502]  sdhci mmc_core video fjes i2c_hid hid_logitech_dj ecryptfs encrypted_keys trusted tpm
[43072.964512] CPU: 0 PID: 21845 Comm: kworker/0:3 Tainted: G        W       4.5.5-300.fc24.x86_64 #1
[43072.964514] Hardware name: ASUSTeK COMPUTER INC. UX305FA/UX305FA, BIOS UX305FA.211 07/02/2015
[43072.964547] Workqueue: events intel_mmio_flip_work_func [i915]
[43072.964550]  0000000000000286 00000000828da65e ffff88009db23d10 ffffffff813d35af
[43072.964554]  ffff88009db23d58 ffffffffa0232e60 ffff88009db23d48 ffffffff810a5f12
[43072.964557]  ffff8801a59928c0 ffff88021ec165c0 ffff8800cc5bb840 ffff8801a59928c8
[43072.964561] Call Trace:
[43072.964567]  [<ffffffff813d35af>] dump_stack+0x63/0x84
[43072.964572]  [<ffffffff810a5f12>] warn_slowpath_common+0x82/0xc0
[43072.964575]  [<ffffffff810a5fac>] warn_slowpath_fmt+0x5c/0x80
[43072.964606]  [<ffffffffa01caf2c>] intel_mmio_flip_work_func+0x47c/0x490 [i915]
[43072.964611]  [<ffffffff810be7e4>] process_one_work+0x184/0x440
[43072.964614]  [<ffffffff810beaee>] worker_thread+0x4e/0x480
[43072.964618]  [<ffffffff810beaa0>] ? process_one_work+0x440/0x440
[43072.964621]  [<ffffffff810beaa0>] ? process_one_work+0x440/0x440
[43072.964624]  [<ffffffff810c49c8>] kthread+0xd8/0xf0
[43072.964627]  [<ffffffff810c48f0>] ? kthread_worker_fn+0x180/0x180
[43072.964632]  [<ffffffff817cf03f>] ret_from_fork+0x3f/0x70
[43072.964635]  [<ffffffff810c48f0>] ? kthread_worker_fn+0x180/0x180
[43072.964637] ---[ end trace d076bf359b9a0f7c ]---
[43072.966503] drm/i915: Resetting chip after gpu hang
Comment 5 jean.wicht 2016-06-12 10:17:35 UTC
It seems all the crashes I was experiencing are solved by mesa 12.0.0-rc1. I suppose you can close this bug report. Thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.